Performance Test ends early with error: "Failed to collect statistics from Controller..."

Hi All,

I am using PC 12.01 version and facing one issue. When I run a load test, it mostly stops in between 5 - 45 minute mark.  Steady state duration is 1 hour but unfortunately it never finishes the test. The error shown in the event log says "Failed to collect statistics from controller, internal error: "There was an error reading form the pipe: The pipe has been ended. (109, 0x6d).

"Failed to collect statistics from Controller, internal error: 'This request operation sent to net.pipe://localhost/CntrlService/Service did not receive a reply within the configured timeout (00:20:00). The time allotted to this operation may have been a portion of a longer timeout. This may be because the service is still processing the operation or because the service was unable to send a reply message. Please consider increasing the operation timeout (by casting the channel/proxy to IContextChannel and setting the OperationTimeout property) and ensure that the service is able to connect to the client.'

"Failed to stop test. Reason: 'The request channel timed out while waiting for a reply after 00:10:00. Increase the timeout value passed to the call to Request or increase the SendTimeout value on the Binding. The time allotted to this operation may have been a portion of a longer timeout. The HTTP request to 'http://pcctrl01.solon.prd:8731/LTOP/LoadTestingService/LoadTestingService' has exceeded the allotted timeout of 00:10:00. The time allotted to this operation may have been a portion of a longer timeout.'

Can anybody help me here as I am clueless how to proceed. facing this issue sincs last week only. earlier it was working fine for me.

Attaching event logs here

  • Hello,

    This issue requires a closer look by HPE Support team. It is hard to troublesoot via the forum.

    I suggest to open a ticket so we can investigate.



  • For the recommedation option would be:

    Remove the monitor opitons if it is enabled, in scenario like Diagnostics page, J2EE, etc.

    Please uncheck that if it enabled.

    The second option would be need to check the parameters and its naming conventions.  If you do this two you will be able to resolve that issue most of the time. Thanks.

  • Hello Shlomi,

    Just wanted to verify if this issue been addressed as I am facing identical errors during my test runs.
    However, there is a difference in my case.
    If I run the tests from performance center everything works fine.
    I get these errors only when I run the same test via the LR API to trigger the test as documented here  in the API documentation.
    My scenario is of one hour duration and I start getting the errors anytime after approximately 30 mins in 'Event log' in ALM for the particular run id. Also, once this error occurs the test anyways fails and ends up with 'Run Failure' state and provides inaccurate/partial/unreliable results in the analysis file.

    However, it would run fine if I reduce my scenario duration. (I have had one successful run for the same scenario with 5 mins of duration designed)

    The version of the Performance Center being userd in 12.20.(The API documentation points to 12.53. During development we were refering 12.20 documentation which now had been taken down)

    Awaiting your reply.