[LRE TIPS] - WcfBridge.WcfCommunicationException: Failed to communicate with the remote WCF service.

1 Likes
over 1 year ago

Symptoms

When adding LRE Host, you may see below error in LRE Server log:

2020-04-06 15:12:34,496 [4808] [38] ERROR WcfBridge.WcfCaller - Error sending WCF request [Context: (null)] [FullContext: (null)]
WcfBridge.WcfCommunicationException: Failed to communicate with the remote WCF service. Connection Info: ILabService
ServerUrl: http://xxxxxxxxxxxxx
Domain: DEFAULT, Project: LAB_PROJECT, User: xxxxxxxxx.

Binding Info: ILabService
ServerUrl: http://xxxxxxxxxxxxx
Domain: DEFAULT, Project: LAB_PROJECT, User: xxxxxxxxx.
---> System.ServiceModel.FaultException:
Change Machine Identity failed. Reason: No connection could be made because the target machine actively refused it.
For more information, please check the logs.
at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)
at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(MethodCall methodCall, ProxyOperationRuntime operation)
at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(MethodInfo targetMethod, Object[] args)

Solution

The issue occurs because LRE Host cannot communicate with LRE backend service over port 5876 (default port)

Staying on LRE Server and LRE Host, try to access http://LREServer:5876 and make sure you can access it, if not make the port 5876 is open from LRE Host to LRE Server

Tags:

Comment List
Anonymous
  • Hi,

    I run LRE 2020SP3 without any TLS-Security so long on a test server. When I do a netstat -an I only get a listener for port 5876 on "::1" and on "127.0.01" That's why I can't acces from my host or LG. What's wrong with my installation?

Related Discussions
Recommended