What can cause a "Report Service responds with error code 500" error when viewing Birt reports?

0 Likes

Problem:

What can cause a "Report Service responds with error code 500" error when viewing Birt reports?

Resolution:

It has been reported that when viewing the overview report or any other Birt based reports within SilkCentral Test Manager 2008 the user may be presented with the following error:

Chart Server error

URL = "
http://localhost:19126/BirtServer"

Message = Report Service responds with error code 500

Upon examination of the Chart Server log file look for the following entry:

birt.report.engine.api.EngineException: Some required parameter values are not set or set to incompatible data type.

This is referencing the connection string passed to the database.

This issue tends to occur where users have installed their own full MSSQL database. When creating a user for connecting to the database the use may not have specified a password, opting for an empty/blank password.

When setting the connection within SilkCentral Test Manager to the database all is well and a successful connection can be made with the credentials, however the connection data passed to the Brit chart server will cause this issue, ie the connection string is in the form of sa, “” …..

To resolve this issue you must specify a password for the user credential used to connect to the database.

  • Launch SQL Server Enterprise Manager. Navigate the tree to the Security | Logins node
  • In the list of users select the once used to create the Connection to the database within SilkCentral Test Manager, here it is “sa”

  • Right click and select properties,In the dialog which appears ensure the following are set:
  • SQL Server Authentication is checked
  • A password is provided in the password field,

  • Select Ok and close out of Enterprise manager.

  • Launch SilkCentral Test Manager and navigate to Administration | System | Database tab
  • Select Disconnect from database.
  • In the password field enter the new password for the connection string. Select connect to database.

  • You should now be re-connected to the database.
  • Navigate to Activities | Overview. The Brit reports should now be rendered correctly
Rendered Report

Old KB# 25042
Comment List
Anonymous
Related Discussions
Recommended