Cloned Silk Central image points to the wrong database

0 Likes

A virtual image has been made of a real Silk Central installation. The Silk Central installation is complete i.e. it has the frontend, application, chart and report servers all on the same machine.

The original database is backed up and then restored under a new name.

The cloned image is disconnected from the original database and connected to the new, renamed database. However, the original (physical) Silk Central installation now also automatically connects to the new, renamed database.

The problem is caused by the appserver.ini settings.

The connection to the database is managed by the application server. The host where the application server is running, is set in a file called "appserver.ini". This file contains just two lines,

  • The hostname of the application server 
  • The port (19122) the application server is running on

The file should be in C:\ProgramData\SilkCentral.

To fix the problem reconfigure the appserver.ini on the cloned image:

  1. Disconnect database on the cloned Silk Central image 
  2. Stop all SCTM services on the cloned Silk Central image 
  3. Open appserver.ini on the cloned Silk Central image and change the hostname to that one where the application server of the cloned Silk Central image is running 
  4. Save file and restart Silk Central services on the cloned Silk Central image 
  5. Connect the database on the cloned Silk Central image again

It should now be possible to connect to individual databases from both the physical and the cloned Silk Central installation.

 

Comment List
Anonymous
Related Discussions
Recommended