Why are BIRT Reports Data Sets not showing all of the database tables and views that exist?

0 Likes

Problem:

Why are BIRT Reports Data Sets not showing all of the database tables and views that exist?

Resolution:

When Browsing the Available Items within a Data Set, only some of the tables/views with the prefix SCC_ appear and none with the prefix TM_ appear.

This is because the Available Items within a Data Set limit is set to a maximum 100 objects. As there are more than 100 tables/views within the SilkCentral Test Manager Database, there are a number of items that will not initially appear.

To limit the amount of items that appear within the Available Items browser window use the filter to narrow the number of results.

This can be achieved by using the prefix of a table or views name, specifying a Type and clicking "Apply Filter" Button

The default limit of 100 objects can be changed within Birt Reports by going to Window| Preferences and expanding Report Design | Data Set Editor | JDBC Data set - then increase the field number in the Maximum number of tables in each schema to display.


Old KB# 25070
Comment List
Anonymous
Related Discussions
Recommended