Problem:
Resolution:
The following Null Pointer Exception can be displayed when accessing "Issue Tracking > Configuration > User Accounts" in SCTM:
HTTP Status 500 -
--------------------------------------------------------------------------------
type Exception report
message
description The server encountered an internal error () that prevented it from fulfilling this request.
exception
javax.servlet.ServletException: java.lang.NullPointerException
com.borland.bca.webgui.core.BcaServlet.refineExceptionAndRethrow(BcaServlet.java:244)
com.segue.scc.webgui.SccFrontendMainServlet.handleUserRequest(SccFrontendMainServlet.java:137)
com.borland.bca.webgui.core.BcaServlet.dispatchUser(BcaServlet.java:160)
com.borland.bca.webgui.core.BcaServlet.doGet(BcaServlet.java:74)
javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
com.borland.bca.webgui.core.EncodingFilter.doFilter(EncodingFilter.java:20)
root cause
java.lang.NullPointerException
com.segue.radar.webgui.module.units.configuration.UserView.loadTable(UserView.java:258)
com.segue.radar.webgui.module.units.configuration.UserView.(UserView.java:93)
com.segue.radar.webgui.module.units.ConfigurationUnit$1.selectionPerformed(ConfigurationUnit.java:342)
com.borland.bca.webgui.internal.html.tree.DefaultTree.notifySelectionListeners(DefaultTree.java:637)
com.borland.bca.webgui.internal.html.tree.DefaultTree.setSelectedNode(DefaultTree.java:341)
com.borland.bca.webgui.internal.html.tree.DefaultTree.setSelectedNode(DefaultTree.java:335)
com.segue.radar.webgui.module.units.ConfigurationUnit.selectNode(ConfigurationUnit.java:478)
com.segue.radar.webgui.module.units.ConfigurationUnit.selectNode(ConfigurationUnit.java:475)
com.segue.radar.webgui.module.units.ConfigurationUnit.processRequest(ConfigurationUnit.java:463)
com.segue.scc.webgui.component.HtmlServletPage.display(HtmlServletPage.java:742)
com.segue.scc.webgui.SccUser.handleRequest(SccUser.java:456)
com.segue.scc.webgui.SccFrontendMainServlet.handleUserRequest(SccFrontendMainServlet.java:127)
com.borland.bca.webgui.core.BcaServlet.dispatchUser(BcaServlet.java:160)
com.borland.bca.webgui.core.BcaServlet.doGet(BcaServlet.java:74)
javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
com.borland.bca.webgui.core.EncodingFilter.doFilter(EncodingFilter.java:20)
The error can occur if you have made a copy of a project in SCTM and are trying to acccess the copied project (not the original). To resolve the error you can do the following:
1) In SCTM go to the “Issues” tab and select the original Issue Manager Project.
2) Next go to “Issues | Configuration | Groups” and observe (make a list) the list of configured groups in the column.
3) Go to User Accounts.
4) View the column "Settings Groups" and verify if any group specified in the column does not also match the configured Groups section (as noted in point 1).
5) If you observe any differences when comparing the groups (see point 1 and 3) then modify the “Settings Group” for the user account so that it matches the group defined in the Groups section (in point 1)
6) Alternatively you can add these missing groups in the Groups section.
Once these steps are followed this issue will no longer occur in the copied project.