Error while launching MS Edge 96.0.1054.29 with Silk4j 20.5

Hi ,

     I have the below versions on my machine and i am trying to launch MS Edge using the browser Base state method

  • Silk4j 20.5
  • MS Edge 96.0.1054.29

I have followed the steps given in the below page to support the higher version of MS Edge

Testing Additional Browser Versions (microfocus.com)

  1. Placed the ms edge driver for version 96.0.1054.29 in the folder 'C:\Program Files (x86)\Silk\SilkTest\ng\WebDrivers\Windows\Edge\96.0.1054.29'
  2. updated the properties file in the path 'C:\Program Files (x86)\Silk\SilkTest\ng\WebDrivers\Common\Config\Edge'

Error message : 

  • Failed to start application 'Edge'. Window of started Edge cannot be accessed. This may be due to UAC being turned off; please make sure that UAC is enabled otherwise Edge cannot be started.

Code :

                    BrowserBaseState baseState = new BrowserBaseState("silk4j2.settings");

                     baseState.setBrowserType(BrowserType.Edge);

                     baseState.setOption(CommonOptions.OPT_SYNC_TIMEOUT, 120000);

                     baseState.setOption(CommonOptions.OPT_WAIT_RESOLVE_OBJDEF, 20000);

                     baseState.setExecutable("C:\\Program Files (x86)\\Microsoft\\Edge\\Application\\msedge.exe");               

                     baseState.setWorkingDirectory("C:\\Program Files (x86)\\Microsoft\\Edge\\Application");       

                     baseState.setExecutablePattern("*\\msedge.exe");

                     baseState.setLocator("//BrowserApplication");

                     baseState.setUrl(URL);

                     baseState.execute(desktop);

                     desktop.<BrowserApplication>find("//BrowserApplication").maximize();

Please let me know the solution . I checked the 'EnableLUA' in reedit and it is enabled too

Regards,

Raghavan.S

Parents Reply Children
  • Hi Robert , 

      Thanks for the quick response

    1. Yes , I have installed SilkTest 20.5 HotFix 2

    2. The software upgrade to SilkTest 21 has to be rolled out by the organisation and i cannot update it on my own. So Could you please help me out with a way to work with MS Edge 9 with Silktest 20.5

    Should it not still work when i have done the workaround steps mentioned in the microfocus page?Testing Additional Browser Versions (microfocus.com)

    Regards,

    Raghavan.S

  • Hi Robert ,

     In addition to the error message i have mentioned earlier , i could also see that the Microsoft Edge icon in the taskbar below but there is an error popup blocking it from opening.

    The error popup has the message 'We can't load the extension from C:\users\xxxx\AppData\local\Temp\scoped_dirxxxx\internal.Loading of unpacked extensions is disabled by the administrator.'

    Could you please let me know if there is any resolution for this issue related to access privileges?

    Regards,

    Raghavan.S

  • Hi

    It may be bes to open a support case so that an engineer can investigate this.

    The only other reason that I am aware that causes this error, would be if your Silk Test client or the Open Agent is configured to "Run as Administrator" by default. Can you check the properties for "eclipse.exe" and "openAgent.exe" and ensure that neither are configured to "Run as administrator" by default?

    Regards
    Robert