Keyword driven test, Silk4J, when executing test thru command line KeywordNotFoundException: Keyword not found

I have a Silk4j project.

I follow the documentation Replaying Keyword-Driven Tests from the Command Line (microfocus.com)

in my tests.jar file my class with my keywords are present

when I ran 

java org.junit.runner.JUnitCore myJunitTest

I get the following error

JUnit version 4.12
.GoogleFolder/google_selenium
com.borland.silk.keyworddriven.engine.exceptions.KeywordNotFoundException: Keyword 'DisplayInfo' not found
at com.borland.silk.keyworddriven.engine.AbstractKeywordRunner.executeStep(AbstractKeywordRunner.java:212)
at com.borland.silk.keyworddriven.engine.AbstractKeywordRunner.executeKeywordSequence(AbstractKeywordRunner.java:

Does someone has a clue, an idea?


Thanks for help

  • Suggested Answer

    Hi Patrick,

    The stack trace would appear to indicate that you have an unimplemented keyword named "DisplayInfo".

    It looks like the keyword in question is being used in a Keyword Sequence but that is all I can ascertain from the information above.

    Regards
    Robert

  • Hi Robert

    thanks for your answer.

    II solved my problem.

    The cause was another keyword that was implemented in my class.

    Although this keyword worked when running from Eclipse, the command line execution returned this error referring to a correct keyword.

    I regenerated the keyword in error, for some unknown reason, and now it works.

    Thanks again for your help