Silk4NET: How to Solve Service function 3 could not be found Error?


Silk4NET: The below error is displayed when Record option and Record New Entry option in object map. Also script is not executing.

I have restarted the open agent process, but  issue is not solved.

Tried to execute on  Silk Test Workbench tool, the script is not executed. same issue in Silk Test Workbench Tool


High Priority Issue: Can anyone help me to fix this issue?

  • Suggested Answer


    I believe errors such as these indicate that a child process of the Open Agent has crashed or not started.

    Can you check if there are any errors in the Windows Event Viewer related to any of the following processes?

    • osServiceProvider_x86.exe
    • osServiceProvider_x64.exe
    • AgentHelper_x86.exe

    I would however suggest that you open a new support case so that an engineer can investigate the problem and collect the required logs for analysis.

    Additionally, you could also try to reinstall Silk Test in the event you recently received a Windows update that removed a Silk Test dependency.