ERROR: Setup has detected that unInstallShield is in use

0 Likes

Problem:

ERROR: Setup has detected that unInstallShield is in use

Resolution:

ERROR: "Setup has detected that unInstallShield is in use"


Information in this Brief applies to:

  • StarTeam 4.x, 5.x

Problem: Error Message, Setup has detected that unInstallShield is in use. Please close unInstallShield and restart setup. Error 432, Appears When unInstallShield Is Not Running

The following article is published by InstallShield at the following location:

http://support.installshield.com/kb/view.asp?pcode=ALL&articleid=Q104333

Document ID: Q104333

This article applies to the following:
Product(s): InstallShield 5.x Professional
Last Revised On: 09/20/2001


Symptoms

When I try to run my setup on a particular machine I get error 432 during the setup initialization. The error says that unInstallShield is running, but it is not. There is nothing else running in the background nor is anything related to InstallShield running in the Task Manager. Why is this happening?


Cause

This could be happening if IsUninst.exe is corrupted on a particular machine. This could also happen if the user running the setup does not have administrative rights. IsUninst.exe is the InstallShield uninstallation file, and when it is corrupted it might appear to be in use even though it is not showing up as a process that is running in the Task Manager.


Resolution

Verify that the user has administrative privileges. Delete all instances of IsUninst.exe from the Windows directory and try running your setup again. If IsUninst.exe cannot be deleted because it is in use, try to reboot the machine and run the setup again.

Old KB# 28476
Comment List
Related
Recommended