I need to compile my Java programs in JRE 1.4, but my StarTeam Eclipse edition requires 1.5 or later. How can I successfully compile my Java applications using JRE 1.4?

0 Likes

Problem:

I need to compile my Java programs in JRE 1.4, but my StarTeam Eclipse edition requires 1.5 or later. How can I successfully compile my Java applications using JRE 1.4?

Resolution:

  • Product Name: StarTeam Eclipse
  • Product Version: 3.1
  • Product Component: n/a
  • Platform/OS Version: Windows
  • JDK/Compiler Version: less than JRE 1.5

Question:

I need to compile my Java programs in JRE 1.4, but my StarTeam Eclipse edition requires 1.5 or later. How can I successfully compile my Java applications using JRE 1.4?


Answer:

You can either force Eclipse to use a specific version of Java or you can take this opportunity to use a later version of Java. If you cannot use a later version then do the following in Eclipse.

  1. Open StarTeam Eclipse
  2. Choose Windows | Preferences
  3. Expand Java | Installed JREs.
  4. From here you can specify which JRE you wish to use when compiling programs through Eclipse.
  5. Please note, you must have the relevant JREs installed on the local machine before performing this.

Author: Andrew Thompson

Old KB# 27532
Comment List
Related
Recommended