The class "com.starbase.starteam.gui.StarTeamFrame" must be public when starting CrossPlatform Client

0 Likes

Problem:

The class "com.starbase.starteam.gui.StarTeamFrame" must be public when starting CrossPlatform Client

Resolution:

Q. I"m getting the following error when trying to start the CrossPlatform Client:

Unable to locate the application"s "main" class. The class "com.starbase.starteam.gui.StarTeamFrame" must be public and have a "public static void main(String[])" method. (LAX)

A. The CrossPlatform client requires JDK 1.4 and appears to be using the wrong JDK version. Edit the LAX file that is associated with the Cross-Platform client, find the line:


lax.nl.current.vm=

Make sure it points to a JDK version 1.4.

Old KB# 28205
Comment List
Related
Recommended