Why do I get the error "Oracle ODBC driver version 10. xx.xxxx. may not yet be supported by StarTeam Server"?

0 Likes

Problem:

Why do I get the error "Oracle ODBC driver version 10. xx.xxxx. may not yet be supported by StarTeam Server"?

Resolution:


  • Product Name: StarTeam
  • Product Version: 2006
  • Product Component: Database
  • Platform/OS Version: N/A

The reason for this is that you are using the wrong version of Oracle drivers for the Oracle 10g database you are using for the StarTeam server.

To confirm that you are using the wrong Oracle driver you can check your log file, this will be simialr to below:

1 00000001 2007-07-19 15:10:49 *********Starting boot log*********
2 00000001 2007-07-19 15:10:49 StarTeam Server version: 9.0.244 configuration: Oracle
3 00000002 2007-07-19 15:10:49 Oracle ODBC driver version 10.02.0001 may not yet be supported by StarTeam Server.
4 00000001 2007-07-19 15:10:49 Microsoft Windows XP Service Pack 2 (Build 2600)
5 00000001 2007-07-19 15:10:49 DSN: Oracle, ODBC driver version: Oracle in OraClient10g_home1 10.02.0001

As you can clearly see the driver version is stated on line 3 of the log file. This driver is not supported as per the Oracle database driver support detailed at Which version of the Oracle Client is required for Oracle 10g?

To fix this you need to use the Oracle Universal Installer to install the support driver version.

Please note that when attempting to install the supported driver versions (Oracle 10.1.0.4.0 , Oracle 10.1.0.5.0 ) you might notice that the Unversal Installer will not allow you to select and install these versions. The reason for this is that you are using the wrong version of Universal Installer that does not permit these driver versions to be installed. If this is true you will need to use Universal Installer version 10.1.0.3. This version will allow you to pick up the driver versions you need for StarTeam.

This version can be downloaded as part of oracle 10.1.0.3 patch for database server.


Old KB# 28753
Comment List
Related
Recommended