Error:Exception of type 'System.Exception' was thrown.

Hi Team,

I configured Proxy in my system but i am getting the below error and messages are not getting captured.

Error:
Exception of type 'System.Exception' was thrown.

I tried with localhost and my laptop name also. PFA and advise me where i am doing wrong here.

http://lp-5cd742bscv:8101/ServiceSimulation/Demo/MemberAccounts

http://localhost:8101/ServiceSimulation/Demo/MemberAccounts

 

Thanks & Regards,

Saikiran Garapati.

 

Parents
  • Hi Saikiran,

    Is this a REST demo? What batch file are you using to start it? Did you modify something in the demo?

    Can you see more detailed error in the Claim Processing Service window?

     

     

     

  • Hi Jakub,

     

    Is this a REST demo?

    Yes It is REST Demo only

    What batch file are you using to start it?

    run-xml

    Did you modify something in the demo?

    No i did not modify anything.

    Can you see more detailed error in the Claim Processing Service window?

    No I am not seeing anything in the Claim Processing Service window when it is in Proxy, With out proxy I am getting following message:

    Using MemberAccounts at:
    lp-5cd742bscv:8101/.../MemberAccounts
    using configuration:
    -> security=None
    -> message format=Xml
    -> using system default http proxy
    The ClaimProcessing is ready at:
    lp-5cd742bscv:8102/.../ClaimProcessing
    Press <ENTER> to stop the service.

    enterClaim(Hercule, Poirot, 554-98-0001, $24)
    MemberAccounts.memberSearch(): GET /accounts?firstname={firstName}&lastname={lastName}&SSN={socialSecurityNumber}
    -> found 1 member (response time: 431 ms).
    MemberAccounts.getMemberPlan(): GET /accounts/{memberId}/plan
    -> got Allpay Total 1000 plan with $1000 approval limit and $0 total claimed (response time: 192 ms)
    MemberAccounts.getMemberDetail(): GET /accounts/{memberId}/detail
    -> got Name[Hercule Poirot] details (554-98-0001, 4/1/1876...) (response time: 349 ms).
    MemberAccounts.updateMemberPlan(): GET /accounts/{memberId}/plan
    -> #0: Claim(Hercule Poirot, 554-98-0001, 1/1/2010, $24: approved), approved
    getClaim(#0)
    enterClaim(Hercule, Poirot, 554-98-0001, $24)
    MemberAccounts.memberSearch(): GET /accounts?firstname={firstName}&lastname={lastName}&SSN={socialSecurityNumber}
    -> found 1 member (response time: 212 ms).
    MemberAccounts.getMemberPlan(): GET /accounts/{memberId}/plan
    -> got Allpay Total 1000 plan with $1000 approval limit and $24 total claimed (response time: 210 ms)
    MemberAccounts.getMemberDetail(): GET /accounts/{memberId}/detail
    -> got Name[Hercule Poirot] details (554-98-0001, 4/1/1876...) (response time: 305 ms).
    MemberAccounts.updateMemberPlan(): GET /accounts/{memberId}/plan
    -> #1: Claim(Hercule Poirot, 554-98-0001, 1/1/2010, $24: approved), approved
    getClaim(#1)

    I observed both ClientProcessService Window and MembrAccountService Window having same endpoint and port number.

    PFA. and when i configure proxy it is coming http:localhost, generally it should come as only localhost or hostname right? Is that causing any problem.

     

Reply
  • Hi Jakub,

     

    Is this a REST demo?

    Yes It is REST Demo only

    What batch file are you using to start it?

    run-xml

    Did you modify something in the demo?

    No i did not modify anything.

    Can you see more detailed error in the Claim Processing Service window?

    No I am not seeing anything in the Claim Processing Service window when it is in Proxy, With out proxy I am getting following message:

    Using MemberAccounts at:
    lp-5cd742bscv:8101/.../MemberAccounts
    using configuration:
    -> security=None
    -> message format=Xml
    -> using system default http proxy
    The ClaimProcessing is ready at:
    lp-5cd742bscv:8102/.../ClaimProcessing
    Press <ENTER> to stop the service.

    enterClaim(Hercule, Poirot, 554-98-0001, $24)
    MemberAccounts.memberSearch(): GET /accounts?firstname={firstName}&lastname={lastName}&SSN={socialSecurityNumber}
    -> found 1 member (response time: 431 ms).
    MemberAccounts.getMemberPlan(): GET /accounts/{memberId}/plan
    -> got Allpay Total 1000 plan with $1000 approval limit and $0 total claimed (response time: 192 ms)
    MemberAccounts.getMemberDetail(): GET /accounts/{memberId}/detail
    -> got Name[Hercule Poirot] details (554-98-0001, 4/1/1876...) (response time: 349 ms).
    MemberAccounts.updateMemberPlan(): GET /accounts/{memberId}/plan
    -> #0: Claim(Hercule Poirot, 554-98-0001, 1/1/2010, $24: approved), approved
    getClaim(#0)
    enterClaim(Hercule, Poirot, 554-98-0001, $24)
    MemberAccounts.memberSearch(): GET /accounts?firstname={firstName}&lastname={lastName}&SSN={socialSecurityNumber}
    -> found 1 member (response time: 212 ms).
    MemberAccounts.getMemberPlan(): GET /accounts/{memberId}/plan
    -> got Allpay Total 1000 plan with $1000 approval limit and $24 total claimed (response time: 210 ms)
    MemberAccounts.getMemberDetail(): GET /accounts/{memberId}/detail
    -> got Name[Hercule Poirot] details (554-98-0001, 4/1/1876...) (response time: 305 ms).
    MemberAccounts.updateMemberPlan(): GET /accounts/{memberId}/plan
    -> #1: Claim(Hercule Poirot, 554-98-0001, 1/1/2010, $24: approved), approved
    getClaim(#1)

    I observed both ClientProcessService Window and MembrAccountService Window having same endpoint and port number.

    PFA. and when i configure proxy it is coming http:localhost, generally it should come as only localhost or hostname right? Is that causing any problem.

     

Children