Getting error while debugging or running BPT test from ALM Test Plan Module | Need Assistance

Hi All, 

Whenever we run or debug any BPT teset case from ALM Test Plan module, it throughs error message “Object reference not set to an instance of an object”  (screenshot attached) instead of displaying the execution results.

This is happining for all BPT test cases in all the ALM projects. And surprisingly, when we run the same BPT test case directly from UFT, it run perfectly fine.

We have tried clearing all the existing ALM Web Client (using ALM Cleanup utility) and reinstalling the ALM 12.55 Web Client, reinstalling UFT and even created new ALM project from scratch, but we are still getting the same error. 

Any help in this regard will be much appriciated.

 Enviornment Details

  • ALM -> 12.55.358 (Patch 1) , installed on Linux server
  • Database: Oracle 12 C
  • UFT -> Tried with UFT 14.00, 14.02 and 14.50, with all the default setting.

Screenshot of error

Getting error while debugging or running BPT test from ALM Test Plan Module.jpg

 Steps to reproduce the error:

  1. Created a new ALM project (just to make sure that the issue is not related to specific project), with 'ALM Lab Extension for functional and performance testing' Project Extension.
  2. Created new Application Area from UFT, using Web Add-in.
  3. Created new BPT component from UFT , with just one Reporter.Reportevent Statement.
  4. Created the Business Process Test inside ALM Test Plan Module
  5. From ALM Test Plan -> Run / Debug the BPT test.

Please let me know if you need any other details.

Thanks & Regards,

Prakash Maurya


Parents Reply Children
No Data