Users unable to open Workbench all of a sudden... 9.14 on Linux

Our QV environment Version 9.14.0007   started intermittently not allowing us to open the Workbench this week.   It has gotten worse and today no one can open the workbench at all.   The system has been up and running for almost 2 years.   No changes were made to PPM that I know about.   However the Linux OS was patched last week, which makes me suspect something with that.  However according to our unix support team nothing related to Java was updated.

 

When you select Open Administration Open Workbench from the Dashboard, the window pops up like its trying to open the workbench.  However its usually completely white and empty.  I turned on Java console and when that pops up, I just see the console options and thats about it.  Nothing else displays.

 

We have tried stopping PPM clearing cache deleting work and tmp cachemanager and nothing is helping.

 

Has anyone run into this or know what to try?  

 

 

load: class com.kintana.core.gui.DownloadApplet.class not found.
java.lang.ClassNotFoundException: com.kintana.core.gui.DownloadApplet.class
 at sun.plugin2.applet.Applet2ClassLoader.findClass(Unknown Source)
 at sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Unknown Source)
 at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
 at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
 at java.lang.ClassLoader.loadClass(Unknown Source)
 at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Unknown Source)
 at sun.plugin2.applet.Plugin2Manager.createApplet(Unknown Source)
 at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
 at java.lang.Thread.run(Unknown Source)
Caused by: java.io.IOException: open HTTP connection failed:https://xxxxxxxx.com/itg/web/knta/global/com/kintana/core/gui/DownloadApplet/class.class
 at sun.plugin2.applet.Applet2ClassLoader.getBytes(Unknown Source)
 at sun.plugin2.applet.Applet2ClassLoader.access$000(Unknown Source)
 at sun.plugin2.applet.Applet2ClassLoader$1.run(Unknown Source)
 at java.security.AccessController.doPrivileged(Native Method)
 ... 9 more
Exception: java.lang.ClassNotFoundException: com.kintana.core.gui.DownloadApplet.class

 

 

 

  • Hello Bzdafro,

    There are so many possibles that can be the root of this issue.  We need to try first with the basic steps

    Workbench connects through the RMI protocol. Therefore, you need to first make sure that you are able to connect to the hostname and port number specified by the server.conf parameter com.kintana.core.server.RMI_URL=rmi://hostname:port/KintanaServer:
    ping
    Example:
    ping steel.merc-int.com

    2. Make sure that the client can resolve the hostname or the IP address for the RMI Hostname machine (from above). This will tell you whether the server can be reached.

    3. If your ITG server is behind a firewall or if you are using a proxy server, make sure that the firewall/proxy server allow an RMI connection with the application server using the specified RMI port.
    Note: HTTP procotcol is not used to connect to the workbench

    4. Check to make sure that a supported version of the Java plug-in is installed on the ITG server by going to the Control Panel and checking the specific version that is installed. The Compatibility Matrix and System Requirements (PDF) provides you the list of supported Java plug-in versions.

    5. If you suspect that there might be a conflict with the Java plug-in version, try going into the Control Panel and uninstalling all the JVMs that are installed on the machine. After doing that, try starting the Workbench. It should automatically download the appropriate JRE version and install it.

    6. Go to Control Panel -> Java Plug-in, and make sure the following items are selected:
    a. Basic Tab
    Show console is enable for troubleshooting.
    b. Browser Tab
    Make sure all the browsers in the list are not selected.

    7. Clear the client-side JVM Cache (Control Panel -> Java Plug-in -> Cache Tab -> Clear). Do so for all Java plug-ins installed.

    8. Clear the Temporary Internet Files and Cookies in Internet Explorer (Tools -> Internet Options -> "Delete Cookies" and "Delete Files"). Close all the browser windows and any Java plug-ins, i.e., JRE icons not in the Windows status bar.

    9. After restarting the browser, log into ITG, and launch the Workbench.

    10. Do you have any pop-up blockers installed? If so, make sure pop-ups are allowed on this Internet Explorer page since opening the Workbench will produce a pop-up page.

    11. To help us with troubleshooting, when the Workbench tries to start up, in the Java Console, press 5, and there should be more troubleshooting information. Attach the error messages. ]

     


    Also , the users are able to open the Workbench from desktop?

     
    Please let me know,

     

    Thanks


    Natalia Rojas

  • Hello Bzdafro,

    There are so many possibles that can be the root of this issue.  We need to try first with the basic steps

    Workbench connects through the RMI protocol. Therefore, you need to first make sure that you are able to connect to the hostname and port number specified by the server.conf parameter com.kintana.core.server.RMI_URL=rmi://hostname:port/KintanaServer:
    ping
    Example:
    ping steel.merc-int.com

    2. Make sure that the client can resolve the hostname or the IP address for the RMI Hostname machine (from above). This will tell you whether the server can be reached.

    3. If your ITG server is behind a firewall or if you are using a proxy server, make sure that the firewall/proxy server allow an RMI connection with the application server using the specified RMI port.
    Note: HTTP procotcol is not used to connect to the workbench

    4. Check to make sure that a supported version of the Java plug-in is installed on the ITG server by going to the Control Panel and checking the specific version that is installed. The Compatibility Matrix and System Requirements (PDF) provides you the list of supported Java plug-in versions.

    5. If you suspect that there might be a conflict with the Java plug-in version, try going into the Control Panel and uninstalling all the JVMs that are installed on the machine. After doing that, try starting the Workbench. It should automatically download the appropriate JRE version and install it.

    6. Go to Control Panel -> Java Plug-in, and make sure the following items are selected:
    a. Basic Tab
    Show console is enable for troubleshooting.
    b. Browser Tab
    Make sure all the browsers in the list are not selected.

    7. Clear the client-side JVM Cache (Control Panel -> Java Plug-in -> Cache Tab -> Clear). Do so for all Java plug-ins installed.

    8. Clear the Temporary Internet Files and Cookies in Internet Explorer (Tools -> Internet Options -> "Delete Cookies" and "Delete Files"). Close all the browser windows and any Java plug-ins, i.e., JRE icons not in the Windows status bar.

    9. After restarting the browser, log into ITG, and launch the Workbench.

    10. Do you have any pop-up blockers installed? If so, make sure pop-ups are allowed on this Internet Explorer page since opening the Workbench will produce a pop-up page.

    11. To help us with troubleshooting, when the Workbench tries to start up, in the Java Console, press 5, and there should be more troubleshooting information. Attach the error messages. ]

     


    Also , the users are able to open the Workbench from desktop?

     
    Please let me know,

     

    Thanks


    Natalia Rojas

  • Working with HP Support but not making much much progress.  Going to check into the BASE_PATH_URL setting.   Ours doesnt have a port at the end which HP support said needs to be there.  However its been like that for 2 years.  We use Tivoli Access Manager for SSO.

     

    I also noticed this in the Java Console log

     

    java.lang.RuntimeException: Failed to load the configuration for LanguageCode
     at com.kintana.core.gui.LogonApplet.setLocale(LogonApplet.java:617)
     at com.kintana.core.gui.WorkbenchApplet.init(WorkbenchApplet.java:108)
     at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
     at java.lang.Thread.run(Unknown Source)
    Caused by: An unknown error has occurred. For more information, please contact your PPM administrator and provide the following GUID number:
    GUID=A1F9F448-85F8-E568-7898-7D0C2981C0F5
     at com.kintana.core.util.mlu.LanguageCode.loadFromURL(LanguageCode.java:97)
     at com.kintana.core.gui.LogonApplet.setLocale(LogonApplet.java:615)
     ... 3 more
    Caused by: java.io.IOException: Server returned HTTP response code: 401 for URL

  • Verified Answer

    Our issue was corrected by changing a setting in our Webseal config file that is used for LDAP load balancing.   Changed "use-http-only-cookies="   from yes to no.