Actual Cost rollup not working

Our actual costs are not rolling up correctly to the work plan or the financial summary. The actual cost displayed is much lower than the true cost.


If I pull a report of all actual time and the costs associated with those hours, that total is correct so apparently its getting lost in the middle somewhere.


Where should I look for this?

  • Hi Cat,


    hope you had a nice weekend.


    Does this happen only for certain entities or for all of them - ie is concerned to be a general problem?


    Can you please let me have a look at your services nodes log (or if you don't have services isolation, please attach the log-file)? I forget which version you are using. Can you also add information that plus SP deployed?


    Have a great day and week.

    Best regards,


  • Great weekend though its TOO HOT! Even for a native Texan.


    I've attached the log file from the services node. I'm not sure which error I should be looking at.


    I've been told we have this problem elsewhere as well, but I cannot confirm it at this time. We get a lot of "the financials aren't right" but that is often due to lack of understanding. In this case though, there's definately a problem.


    We also tried running the PMTMsync process for the project, which ran successfully, and no change.


    PPM 8 Service Pack 3

  • Hi Cat,


    the error looks like you are missign Org Units in the database, resulting in dirty data.


    Check the following and let me know the results:


    select * from KRSC_ORG_UNIT_MEMBERS m where m.ORG_UNIT_ID not in (select org_unit_id from KRSC_ORG_UNITS_NLS);

    Best regards,


  • When i run the query I get one result back and its for a user that we don't use on our projects (different Business unit). It looks like she does belong to an existing org unit. Should I manually remove this extra entry?


    Would that distrupt the financials for projects which she is not a part of?



  • Hi Cat,


    The error states repetitively:


    ERROR :ppmHeavyServiceListenerContainer-1:com.mercury.itg.core.cost:2011/07/18-11:03:20.361 CDT: Error while recalculating the costs of time sheet (time sheet id = 75614), rolling back transaction

    org.hibernate.ObjectNotFoundException: No row with the given identifier exists: [com.mercury.itg.rm.rsc.impl.OrgUnitImpl#100201]


    For whatever reason, the service implies that for a resource that logged time against a timesheet with the ID 75614 while being associated with the Org Unit with the ID 100201 it cannot roll up costs.

    There I would start out with checking WHICH resource has this timesheet and if the resource is IN the Org Unit..


    We can see the same behavior for timesheets

    time sheet id = 78138

    time sheet id = 71902

    time sheet id = 79459

    time sheet id = 66199

    time sheet id = 71904


    etc and also notice that it is always the same Org Unit that is referenced. So, most likely you have an issue with the Org Unit. Check the Org Unit for validity. If need be, I would most likely remove the timesheets and have them recreated.


    If unsure of any procedure, log a ticket before something else breaks, I wouldn’t advise any actions on backend.


    Hope this helps.

    Best regards,


  • I'll create a ticket as you suggested.


    The timesheets the error is referring to is always for the same user. She was modifying org units the other day so I imagine she deleted one in which she was a member. I'd hope PPM would clean that up, but PPM always manages to surprise me.

  • Hi Cat,


    I'm in PPM-support - I'm surprised the day that there ARE no surprises.

    That customers with the fulfilled customer wishes to make everything as flexible as possible ;-)


    Best regards,


  • We are having the exact same issue, and we have determined that the users with time sheets throwing the errors are associated with two org units, one of which is not in the MERCITG.KRSC_ORG_UNITS_NLS.  

    So the issue is in the table, MERCITG.KRSC_ORG_UNIT_MEMBERS. There are duplicate relations to the user ID and an Org ID. Org ID 101485 that relates to an Org Unit that doesn’t exist in the Org Unit table. Any thoughts on resolution?