Lab Service error handshake QTP 11 Win 7

Hi,

 

I Have this issue on  two machine with Windows 7 and QTP 11.

 

Some days ago if i stop and start lab service from system tray I receive windows 32 error call 

 

In one machine I tried to rinstall the lab service and chech host from ALM 11.52 is OK and i can reboot the machine but if I launch a test set from ALM the host became non operational and We have an error like

 

ALM could not lauch test for prolbem handshake initialization.

 

 

For the second machine if i tried to rinstallIo obtain error 1722 msi installation problem for the package.

 

How can i solve?

The second problem is windows problem and i still have resolve but when seem all OK for the host form ALM ( check and reboot ) i can't run test from ALM.

 

Thanks a lot.

  • Hi Marco,

     

    Regarding the handshake error, could you please check if the "Allow service to interact with desktop" option for the HP ALM Lab Service is checked? By default this option is not selected and this may cause the handshake error. In order to check it. please open services.msc, find "HP ALM Lab Service", right click on it, select Properties, go to the Log On tab and make sure that "Allow service to interact with desktop" option is selected. When you select the option, it is recommended to restart the lab service to be sure that the new settings are taken into consideration. If even after making the above change the issue continues to persist, could you chekc whether running the lab service as admin will solve it? Hope this helps!

     

    Thanks,

    Hristo       


  • Hi

     

    Sorry for rising and old thread however this is the only information I have seen on my issue

    I am having the same problem, I can register a host however it failes when doing a check host - handshake error. The machine has Lab Services 11.5 and UFT 12.20 on it. 

     

    I started looking at the HP.ALM.Lab.Agent.RemoteService log and saw Errors

    Task getter has failed: Could not locate an entityNot Found <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3c.org/TR/1999/REC-html401-19991224/loose.dtd" HTML lang=en xml:lang="en" xmlns="http://www.w3.org/1999/xhtml"

    ...

    Your requested host "testqc.abc.xyz.net" could not be resolved by DNS.

    My HP.ALM.Lab.Agent.RemoteService.exe.config contains HostConfig AlmUri="http://testqc.abc.xyz.net:8080/qcbin"

    I am able to get to ALM via this link.

    There is a proxy script in place and I have put the proxy settings in but with no avail.

     

    Any suggestions?

     

  • Managed to fix the issue using config files from a fresh ALM install.

    's advise is good - thanks.

    Also the service needs to run as a local system account - see https://msdn.microsoft.com/en-us/library/aa383840(v=vs.85).aspx - with relevant permissions given to the install location or the service won't start.