Email notification to user list

We have a requirement to send email notifications to user list in addition to Assigned to.  Whatever the changes on defect should send mail to assigned to and that user list.  It is on Quality center version 9.0

 

I have done below steps for this.

 

Customize auto email->selected conditions->selected that user list(at the bottom after assigned to detected by i can see all user lists from that i have selected that user list)->Checked All defects. 

 

But we did not receive any email notification. 

 

Please suggest me how i can set the conditions

Parents
  • Hello QCAdminisrtator,

     

    Please identify the at what conditions should the other sepecific users must get email alerts apart from 'Assigned To'?

     

    Once that is done you need to goto 'Condition' Tab and select one user from that user list and click on 'Condition' tab on the bottom of th page.

     

    A new window will open up that will show all the fields of the defect module. You need to then select the field whose change should alert that user.

     

    Set up a logical condition in the filter and save it.

     

    Repeat the process for remaining users and save all the changes.

     

    This will resolve the issue.

  • What have you set in your "on change of" section?  This is where you define which fields being updated will generate an email notification.  If you only have "Assigned To" in this area, then emails will only be sent if the Assigned To value on the defect is updated.  Emails will not be generated if the Status or Comments are updated, for example.  You need to list any fields that, upon being changed, you want a notification to be sent.

     

    Also, have you marked the Auto Mail option for this project in Site Admin?

  • Your attachments only show the conditions tab.  What is on the Fields tab?  This is where you set "If this field is changed, then send an email".

     

    Are you saying that the user in Assigned To is receiving an email but the user in Business is not?  Since you have "all defects" marked for both user lists they should both be receiving email.  Are you sure that all the users have a valid email address?  Are some of the addresses in a different network/domain?

  • Your attachments only show the conditions tab.  What is on the Fields tab?  This is where you set "If this field is changed, then send an email".

     

    Are you saying that the user in Assigned To is receiving an email but the user in Business is not?  Since you have "all defects" marked for both user lists they should both be receiving email.  Are you sure that all the users have a valid email address?  Are some of the addresses in a different network/domain?

Reply
  • Your attachments only show the conditions tab.  What is on the Fields tab?  This is where you set "If this field is changed, then send an email".

     

    Are you saying that the user in Assigned To is receiving an email but the user in Business is not?  Since you have "all defects" marked for both user lists they should both be receiving email.  Are you sure that all the users have a valid email address?  Are some of the addresses in a different network/domain?

Children
  • Hi Roni,

     

    Thanks for reply. 

     

    Assigned to list of users are getting emails but Business users list are not even i have selected All defects.  emailids and domain address are working from lotus notes. 

     

    Could you please let me know if you have any query to  emails already sent to users.

     

     

  • Are you using the same user list for both fields?  Or did you make a new user list for the 2nd field?

     

    If they are using the same list, I don't know why the automail is not working for your 2nd field.

     

    If you are using a custom user list, I suppose the application does not know how to retrieve the email address.

     

    You could write workflow code which will generate and send the email to the user found in your second field.  Search this forum for SendMail and there should be a few posts regarding how to write that code.

  • Are you using the same user list for both fields?  Or did you make a new user list for the 2nd field?

     

    If they are using the same list, I don't know why the automail is not working for your 2nd field.

     

    If you are using a custom user list, I suppose the application does not know how to retrieve the email address.

     

    You could write workflow code which will generate and send the email to the user found in your second field.  Search this forum for SendMail and there should be a few posts regarding how to write that code.

  • Hi Roni,

     

    I am using the same user list for both fields. 

     

    I did not find exact code for my requirement.  Could you please help me with vb code.

     

    Business contact is BG_USER_30.  Email should send for all changes to assigned to  and Business contact.

     

    Thanks