Lean FT Text Box Issue--Help Needed

Hi All,

 

I have a text boxes available in my web page and button too. When i use "SetValue" method to enter the values in text box it is working fine but when i click on a button the values entered in text box is getting cleared. Not sure why is that happening. I havesmall cross icon at end of the Text box..Do you guys think that is causing the issue?

Please find my code below:

browser.describe(EditField.class, new CSSDescription("#last-name")).setValue("Sample");

browser.describe(WebElement.class, new WebElementDescription.Builder()

.xpath("//BUTTON[@id=\"select-org\"]").build()).click();

After clicking on the button it is getting cleared. It is weired. it would be great if some Lean FT experts can help me out....

Parents
  • No techincal person is there to help me on this? We were struck in middle due to this issue. It is very basic thing not working in Lean FT...How could we buy this for entire organization? Support is really bad...:(

  • You reallly haven't provided much detail about your AUT so it's impossible to answer.  What is the underlying class of the text box?  What's most likely happening is that the text property is getting updated but no change event has occurred so the object is basically ignoring the value (this goes back the underlying class - third party will require additional handling).

    IMO the support forums are simply a resource - I'd open an HP ticket directly for your question.

Reply
  • You reallly haven't provided much detail about your AUT so it's impossible to answer.  What is the underlying class of the text box?  What's most likely happening is that the text property is getting updated but no change event has occurred so the object is basically ignoring the value (this goes back the underlying class - third party will require additional handling).

    IMO the support forums are simply a resource - I'd open an HP ticket directly for your question.

Children