QTP Error - The retrieve DataTable.Value operation failed. The <Col1> Column does not exist.

Hi,

 

One user getting the below error:

Error - The retrieve DataTable.Value operation failed. The <Col1> Column does not exist.

 

If the QTP is opened and run the code, no issues noticed. once the execution is completed after if re-execute using the same QTP session user getting above error.

 

If user close session every time and reopen before execution then no issues, means user should close and open QTP each time.

 

This is not an issue with QTP / Script, because once QTP is opened first time it will execute without any issues.

It is not issue related any settings, because within the execution the same script will execute no of times (iterations) based on input data from data table.

 

If reinstall QTP, couple of days (3-5days) we usually didn't notcie any issue which means, we tried by reinstalling QTP, the first couple of days no issues and after 3-5 days these kind of new issues we are noticed.

We tried by replacing machine also, but no luck.

 

Have monitored RAM usage (using task manger), space is sufficient and didn't reach the utilitzation upto 100%.

 

Note: Other users are able to continue with same script with out any issues.

 

Please let us know if any user notice this kind of issues.

 

Thanks,

Subbarao

Parents
  • Sorry to ask this obvious question,

    Did you tried to debug when that error thrown? i.e. Did you confirmed that the QTP datatable contains that column in the corresponding sheet?

    Keep in mind that column names are case-sensitive.

  • Hi Shanmugavel,

     

    Did you tried to debug when that error thrown?

    The error is occuring in normal execution method, and even Debug mode.

     

    Did you confirmed that the QTP datatable contains that column in the corresponding sheet?

    As i mentioned in my question, the same script with same excel is running first time and if we re-execute the same script with same excel is throwing an error as mentioned above.

    Have verified, data table is loaded and we are able to see loaded data table and Column as well.

    Once the error occured closed QTP and reopen, and then user able to execute the same script with same file without any issues.

     

    User got replaced with new machine, in new machine user able to execute the same scrip with same file around one week without any issues. And then user is getting different issues.

     

    Thanks,

    Subbarao

     

     

Reply
  • Hi Shanmugavel,

     

    Did you tried to debug when that error thrown?

    The error is occuring in normal execution method, and even Debug mode.

     

    Did you confirmed that the QTP datatable contains that column in the corresponding sheet?

    As i mentioned in my question, the same script with same excel is running first time and if we re-execute the same script with same excel is throwing an error as mentioned above.

    Have verified, data table is loaded and we are able to see loaded data table and Column as well.

    Once the error occured closed QTP and reopen, and then user able to execute the same script with same file without any issues.

     

    User got replaced with new machine, in new machine user able to execute the same scrip with same file around one week without any issues. And then user is getting different issues.

     

    Thanks,

    Subbarao

     

     

Children