UFT getting "License Error: Unable to connect to a license server"

Hello people, 

My UFT is not connecting anymore to the license server, I've checked with other users and they are able to launch UFT and connect to the license server (same UFT version), only I can't access it.

Any suggestion? The firewall's ports are all open for the AutoPass License server, I even tried rebooting my laptop, uninstalling and reinstalling UFT, but nothing changed.

Any help please?

Thank you

Tags:

  • Hi Domenico,

    Hope you are doing very well.

     

    - You can check the network connection between the client and server machines by pinging the license server machine in a command prompt window.

     

    - The license server is not running:

    Start or restart the license server service.

    1. Open the Control Panel (Start -> Settings -> Control Panel).
    2. Double-click on Services.

    3. Find the SentinelLM service.
    4. Click <Start Service> (or <Restart Service>) or right-click and choose "Start" (or "Restart").

     

    - Also you may check the ammount of licenses, could be that all the licenses were busy/in use.

    How to check license availability from a license server programmatically:

    https://softwaresupport.hpe.com/group/softwaresupport/search-result/-/facetsearch/document/KM544728

     

     

    -Only one version of the license server should be installed and running on the same machine. If there are more versions, uninstall all of the license server instances (using Add/Remove Programs). Install the latest version of the license server software. Reinstall the license code keys.

     

    -Did you reimage your machine?

     

    Regards,

    ” If you find this or any post useful to resolve the issue, please mark this thread as correct answer and other members can benefit with the information given”

  • Hi Domenico V.

    My department had your exact issue a couple of weeks ago. We got the message, but were able to ping the License server from out UFT box and vice versa. The License server was viable and all was up to date.

    HP gave great assitance to our IT dept which enabled them to narrow down, then finally resolve the problem.  In our case  the situation was caused by a Windows update (WSUS) that was performed.  If your licenses are indeed up to date, then I suggest that you or your Tech dept take a look at any updates that were processed on the day that this issue first occurred. If any are there, back them out then retry connecting to the server.

  • It seems that the problem was related to the old version of the HP AutoPass, installed the 9.2.1 and reinstalled the original license, now everything works as it should.

     

    Thank you all for the possible suggestions (and hope will be good for someone else)

  • I just encountered a similar issue where Windows update KB3172605 (WIN7) caused this problem. After uninstalling it, UFT could connect to the license sever again.

    Edit:

    Just got a reply back from HPE, this issue will be solved when updating the autopass licenseserver. We were still on v8.3, the latest version can be found at: https://hpln.hpe.com/contentoffering/autopass-license-server

  • Hi,

    We are unable to access to concurrent license for our local machine , so we are trying to conecct with VDI.

    How can we connect it without VDI, Do we need any changes to be done ?

     

    Thanks,

    Bhavya.D