UFT 12.5 unable to recognise objects

Hi,

I am working with automating a webpage, but as I run the code, I am getting error stating, 

Cannot find the "[ WebEdit ]" object's parent "[ Browser ]" (class Browser).
Verify that parent properties match an object currently displayed in your application.

Line (3): "Browser("name:=Google","creation time:=0").Page("title:=Google").WebEdit("html tag:=INPUT").Set QTP".

Can anyone please suggest what needs to be done???

I am using UFT 12.5 and Windows7 OS

 

Thanks in advance!

 

  • Hello Manasa1,

    I think you can try to check three things (in this order):

    1. Check that the BHOManager extension is enabled (in the browser you are trying to use).

    2. Check to have the Web add-in selected and associated to your test after starting UFT.

    3. Try using this line instead of yours: Browser("name:=Google*","creation time:=0").Page("title:=Google*").WebEdit("html tag:=INPUT").Set "QTP"

    Sometimes the * helps because titles or names are not always the same.

     

    Let us know :)

    My best regards,

    Alberto

  • Google home page contains multiple elements which have "html tag:=INPUT" (You can find this by inspecting the page)

    Try following

     

    Browser("name:=Google").Page("title:=Google").WebEdit("name:=q").Set QTP"

    You can check the number of objects  matching to specified properties by using ChildObjects method as following. QTP will fail to identify objects if the count of matching objects is zero or more than one

    Set oBrowser = Browser("name:=Google").Page("title:=Google")
    
    Set desc = Description.Create
    desc("micclass").value = "WebEdit"
    desc("html tag").value = "INPUT"
    
    msgbox oBrowser.ChildObjects(desc).count

    Let me know if it works for you

     

  • Hi Alberto,

    Thanks for the solution. I tried to install BHOManager add on but I am not able to re-register it . It is prompting an error. Can you  please suggest me what can be done?

  • Hey, happy that the suggestion was of help.

    Could you please provide the error the add-on is giving to you?

    Just to be sure: you can delete/remove the add-on from Chrome, then go to <UFT_Install_dir>\bin\chrome and you can find the add-on. Drag and drop it inside a Chrome window and it will be re-installed.

    Otherwise, just give me the error description and which operation is raising it to you and we can reason on it.

    Best regs,

    Alberto