QTP not Identifying the Chrome Browser Objects consistently

Hi,


I am finding some issue while executing QTP 11 with Chrome Browser. The object which was identified in IE and Firefox for many times, is not identifying the same object in Chrome Browser for Second or Third Run. There is some inconsistent identifying of Object in Chrome Browser.


Can any one provide me the solution of why this problem arrives..

Tags:

Parents Reply Children
  • Thank you Lei .

     

    Had installed Chrome 19, looks like the chrome default installation location is UserProfile>>Documents & settings....

     

    we want all users should be able to run the script from there machines, so we set the default path to Program files in the script.

    so my script (launch the browser) is failing bcz it couldnt find the chrome.exe in the program files path.

     

    Had tried to get a solution (installing chrome 19 in program files )but no luck.

    is there any way to get the chrome 19 installed in Program files?

  • Hi,

     

    Thanks for your response. Could you try the following code and see if it helps?

     

    MyProcess = "<Chrome path>"

     

    SystemUtil.Run MyProcess

     

    Kind regards,

     

    Lei

  • You need to install the Chrome standalone installer for enterprise in order to get it to install to the Program Files directory. We install and test using the shared, Progam Files installed path on all of our machines here. With the standalone installer, it should install to the ProgFiles dir by default, but I believe there is also a command line switch to specify the install directory when using the offline MSI installer.

     

    https://www.google.com/intl/en/chrome/business/browser/

     

    Depending on version support, you may have to search to find the appropriate version to install if the current one on the site is available as they update often. Also, because Chrome has a nasty habit of updating itself regularly without prompting from the user, I highly recommend locking the version installed down to prevent nasty surprises if it updates by itself. There is a group policy available that you can add (.adm template) to disable the automatic updating. 

  • You need to install the Chrome standalone installer for enterprise in order to get it to install to the Program Files directory. We install and test using the shared, Progam Files installed path on all of our machines here. With the standalone installer, it should install to the ProgFiles dir by default, but I believe there is also a command line switch to specify the install directory when using the offline MSI installer.

     

    https://www.google.com/intl/en/chrome/business/browser/

     

    Depending on version support, you may have to search to find the appropriate version to install if the current one on the site is available as they update often. Also, because Chrome has a nasty habit of updating itself regularly without prompting from the user, I highly recommend locking the version installed down to prevent nasty surprises if it updates by itself. There is a group policy available that you can add (.adm template) to disable the automatic updating. 

  • Hi ,

    I dont find QTP 11 ,QTPWEB_00088.exe  & Patch QTPWEB_00120.

    Can you plz send me .exe files if you have .

    on Mail : eknathsubhash35@gmail.com

     

    Thanks in Advance