Created On:  16 November 2010

Problem:

If your CaliberRM requirements fail to synchronise with SilkCentral Test Manager you should check the SynchLog.log file which can be downloaded from SilkCentral Test Manager GUI at the following location:



The SynchLog.log file can also be found along with the other log files in the following location:

"C:\Documents and Settings\All Users\Application Data\SilkCentral\log"

Resolution:

Check to see if the following error message is reported in your SynchLog:

Warning: Can't create new trace to test definition #97763, reason:
         com.starbase.caliber.security.CaliberSecurityException[message=checkUserCanModify failed because the current user is not an administrator,coClass=null,coid=null,grantedPrivilege=null,userIsAdministrator=false,userIsObjectOwner=false]]

The reason for the error is that the current user is not an administrator in CaliberRM. This is caused because the Caliber SDK is checking the user rights of the user used in the integration settings of SilkCentral Test Manager. You need to ensure that the user used for in integration settings is a member of the administrators group.
Incident #2485513