Created On:  06 September 2012

Problem:

Attempting to run CaliberRM SDK based code in an ASP.NET Project hosted on IIS 7 generates a '80040154 Class not registered' error

Resolution:

If you have CaliberRM SDK code embedded in an ASP.NET project hosted on IIS 7 you may get the following error once it is invoked:

Retrieving the COM class factory for component with CLSID {3AACC1CC-7377-11D5-B316-0800309CC2CE} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).

In the example above I am using the CaliberRM SDK to login to the CaliberRM server. This error will be thrown if you do not have the ‘Enable 32-Bit Applications’ parameter set to ‘True’ for the application pool you are using. At present the CaliberRM SDK only supports 32-bit.

To resolve this error you need to set the ‘Enable 32-Bit Applications’ parameter to ‘True’ for the application pool you are using. See steps below:

- Open IIS 7 Manager
- Select ‘Application Pools’ from the left hand side menu
- Select the application pool you are using for your CaliberRM SDK app on the right hand side menu
- Under Actions select ‘Advanced Settings...’
- Set ‘Enable 32-Bit Applications’ parameter to ‘True’ and click OK
- Restart website for changes to take effect

n/a