IMPORTANT NOTICE:  As of 21 February, anything posted in this community WILL NOT BE MIGRATED to our new community site.   We have pulled all user information and data from this site and are now in an approximately week long process of importing users, roles, and data to our new site.  We are leaving this site open and active so you can post and hopefully get a response until the migration is complete.   Once complete, the URL  that currently takes you to this site will take you to our new site so your bookmarks will work as always.  Please read the information on a New Login Process

Importing XMI file fails

I had tried to export/import a model from Sparx Enterprise Architect v10.0 into Together 12.6 using an XMI-file, but when trying to import the file into Together I only get the following error message:
-------------
Error occured while importing model. Reason: cannot load resource <xmi-filename here>.
Reason: org.eclipse.emf.xmi.PackageNotFoundException: Package with uri
'http://schema.omg.org/spec/XMI/2.1' not found.
(file:/<xmi-filename here>, 3,76)
-------------

Any ideas, how to convince Together to accept that file?

Regards,
Michael Moser

PS:
This microfocus' support contact form is most tedious (at least when used with Internet Explorer 11)! It constantly reloads itself for non-apparent reasons and one then has to restart entering all info again. :-(

PPS: And submitting the form (tried with both, IE 11 and Chrome 33) only yielded the below error message. Thus now trying my luck in this forum...

-------------
Server Error in '/' Application.

Runtime Error
  Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>
 

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>
-------------

  • Hi,

     Unfortunately it is unlikely that you will be able to transfer between Sparx 1.0 and Together 12.6. The issue is that all vendors use slightly different variations on XMI and this makes it difficult when transferring between applications.

    I notice you have logged an incident regarding this, I will communicate through the support incident to see if there is anything we can do in this instance.

    Thanks,

    Gary

  • In reply to GaryR:

    I was afraid, that this would be the answer. Even though every manufacturer of modeling-related SW claims, that they can handle XMI import and export (probably to get a check-mark in buyers requirements list) I have never witnessed so far, that XMI ever worked nor that is was of any use. :-(

    Thanks for responding!

    Regards, Michael

    BTW: I was Sparx EA v10.0 and 11.0 that I tried with, not v1.0 (just in case anybody else ever reads this...).