Together 12.6 Trial Install on Linux

Hi

I'm in the process of installing a trial of Together 12.6, and have already got a fully loaded version of Eclipse 4.3.1 ready.  The Together zip file has been added to the Eclipse install, and it all starts up nicely.....

However, installing the license server is more problematic!

I've obtained the trial license keys and information via email, and have pasted this into a text file.  When running the MFLicenseServerInstall.sh file from the eclipse directory, I get the following errors:

-=-==================================================================-=-
Micro Focus Licensing Installation
www.microfocus.com

(C) 2013 Micro Focus.
./MFLicenseServerInstall.sh: 1: ./MFLicenseServerInstall.sh: ./bin/mfcesver: not found
-e
You can rerun this script at any time to complete
-e the installation of the SafeNet Sentinel Licensing Software.

-e cd /spare/eclipse
-e ./MFLicenseServerInstall.sh

I've logged in as root, and the puzzling part is that the executable listed can't be run, even though I can see it!

Has anyone had issues with the license installation?  All I want to do is run the trial to see if it suits our needs before committing to purchase!

Thanks

  • Hi,

    Which version of Linux are you running this under? Let me know and I will see if I can reproduce any of the issues locally.

  • In reply to GaryR:

    It's ubuntu 14.04 64-bit, with all updates applied.  The Eclipse install was straightforward, just a matter of getting all our required plugins added, to set a baseline, and then unzipping the Together site file into it.  That went fine.

    Up til now we've been running 2008r4, with a .slip file, which has worked fine for us.  Obviously now we need to run a license server, and it's curious how the errors are suggesting that various executables can't be run, even when I'm in as root, and have tried some individually from the command line :(

    BTW, we run Together for many users (approx 25 installations, 1 per PC) - the node-locked license may be a problem  here, but I'm sure we'll cross that bridge once we've got the trial version evaluated properly :)

  • In reply to scomdjp:

    Hi,

      I suspect the problem may be in that you are unzipping the install file rather than actually installing it. Can you try installing Together through the 'Help/Install New Software..' option to see if this resolves the license server issue?

  • In reply to GaryR:

    Sorry, grammatical error!  I installed Together through the "Install New Software" option in Eclipse, and pointed it at the location of the zip file.  It then went through the install process OK and added itself into Eclipse.  So all the pieces look to be in place using the "About Eclipse" option on the Help menu.....

  • In reply to scomdjp:

    Ok no problem. That makes more sense. Let me look into this to see if I can see a problem. I'll get back to you when I have anything.

  • In reply to GaryR:

    Update:

    I've got a bit further now.  It struck me that Together is a 32-bit app, and support for 32-bit apps in 64-bit ubuntu has changed somewhat.  A bit of Googling found a suggestion to add some 32-bit libraries into the system - libc, libncurses and libstdc++ - and then retry the MFServerInstall process.

    This worked better, in that it went through without throwing any errors this time.  I then fired up cesadmin.sh which allowed me to manually add in the licence file I created from the email.  However, choosing option 2 - Check License Status - shows  the following:

    Licensed Products

    =================

    [19-May-2014 15:02:36] v10000.2.01440

    No licenses found.

    So it appears as though the 32-bit libraries are needed, and it will process the license file supplied, but somehow it doesn't run it when the server starts.

    I had to run "startboth.sh" to get  both lserv and mfcesd to run - is this right?

    But, Eclipse (run via ./Together) still won't see the licence, when I try to create a modelling UML 2.0 project I get

    "Micro Focus CES daemon can't be found.  Please install it using MFLicenseServerInstall.sh and run Together using together.sh"

    So, 2 steps forward, 1 step back :)

  • In reply to scomdjp:

    Hi,

      Together is only a 32 bit app if you install it on 32 bit Eclipse. However it works perfectly well with x64 Eclipse as well. It may be an issue due to the version of the license manager which is installed (depending on which Eclipse you go with). It will either install lmsetup86 or lmsetup64 depending on which version is used.

    Would it be possible to try this with 64 bit Eclipse?  Is it the 32 or 64 bit version of the license manager install which is unzipped to your Together folder?

  • In reply to GaryR:

    Done some checking......

    The eclipse install is 64-bit - running "file eclipse" gives the following:

    eclipse: ELF 64-bit LSB  executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.4.0, not stripped

    Running "file mfcesd" in the /var/microfocuslicensing/bin directory gives the following:

    mfcesd: ELF 32-bit LSB  executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.2.5, not stripped

    There are some 64-bit libraries in the bin directory, but the executables report as 32-bit.  So it would appear as though the 32-bit license manager is being installed......

  • In reply to GaryR:

    Can you confirm if it is 64 or 32 but Eclipse? I would still like to run this for myself to test it.

  • In reply to GaryR:

    64-bit

  • In reply to scomdjp:

    Hi,

      Would it be possible for you to log a support incident for this? I am seeing similar behaviour and I think we could better resolve this offline.

  • In reply to GaryR:

    OK, will do

  • In reply to scomdjp:

    ...just been to the "Report an Incident" option on the Supportline, and there doesn't appear to be a way to manually enter the initial information (product, OS, etc) - the only option I can select is our current license for Together 2008

    Is there a way to log an incident using manually-entered information?

  • In reply to scomdjp:

    Hi,

      Go ahead and log it as 2008 and I will pick it up as soon as its logged and make any changes needed.

  • In reply to GaryR:

    Looks like suggestions to add 32-bit libraries may have fixed it.  ia32-libs isn't available in ubuntu 14.04, but it suggests 3 additional packages to add, which are lib32z1, lib32ncurses5, and lib32bz2-1.0

    Adding these, and then reinstalling the license server, and rerunning the cesadmin tool allows the license to be imported and seen.  Eclipse also now allows me to create a new modelling project with no complaints!

    Thanks very much for your help, much appreciated :)

    PS. For information, is the licensing scheme for the Full version of Together based on a node-locked setup, as per the trial, or will we be able to get a multi-seat license, as we have done for TG2008?  We have nigh-on 100 PCs which would be a nightmare to individually setup if node-locked.....