** Upgrading to AccuRev Server 5.6 or higher on Solaris

As of AccuRev 5.6, the AccuRev Server is available only as a 64-bit application; it cannot be installed on 32-bit Solaris machines. The following table summarizes considerations for upgrading existing AccuRev Server installations:

Existing AccuRev Server Version

Comments

4.x

AccuRev 4.x required you to install as root. In AccuRev 5.6 or higher, you cannot install as root. In order to successfully upgrade to AccuRev 5.6 or higher, you must first run the following command on your existing AccuRev installation:

(sudo) chown -R <ac-user> <ac-install>

5.5 and earlier

AccuRev 5.5 and earlier used a 32-bit version of the PostgreSQL database which is not compatible with the 64-bit version of the PostgreSQL database used by AccuRev 5.6 and higher. If you are upgrading from AccuRev 5.5 or earlier, contact AccuRev support for assistance migrating your 32-bit PostgreSQL database: