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Description 
This guide walks through adding SOAR 3.2 to an existing ESM 7.6 deployment. First, we’ll cover ESM 
content that needs to be configured. Next, we’ll install the ArcSight Platform “from the ground up” 
with CentOS 7.9 Minimal installed nodes. Then, we’ll configure SOAR using the Fusion interface and 
install the Forwarding Connector. Finally, we’ll configure SSO with Fusion and ESM. There’s also a 
troubleshooting section, as well as information on integrating SOAR with MITRE ATT&CK and MISP 
(Malware Information Sharing Platform). 
 

Environment 

Our environment has two nodes for the ArcSight Platform, one for the Master and one for the Worker. 
Both nodes are running CentOS 7.9 Minimal installations. ESM is running on a single node in Compact 
Mode, and we have a separate node for the Forwarding Connector. DNS is provided by BIND and all 
nodes can forward and reverse lookup by short names, full names, and IP addresses. The BIND files are 
provided at the end of this guide. 
 

 
 

Software 

• ArcSight Platform 22.1 
o arcsight-platform-installer-22.1.0.16.zip 
o arcsight-installer-metadata-22.1.0.37.tar 
o fusion-1.5.0.37.tar 
o esm-7.6.0.37.tar 

• ArcSight ESM 7.6 
o ArcSightESMSuite-7.6.0.2523.0.tar 
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ArcSight ESM Content 
First, configure the content in ArcSight ESM. There are two users, a rule, and a filter that have default 
values of “change_me” and should be changed. 
 
Installation 

• ESM 7.6 includes the ArcSight ESM SOAR Integration package. With a fresh installation, you can select to 
install this package. On an upgrade, this package is imported but not installed. In the ArcSight Console, 
verify the package has been imported and installed. Resources are under /ArcSight Foundation/. 
 

 
 

 
 

 
 

Users 

• Two Custom Users and User Groups are created. The default password for these users is “change_me” 
and should be changed. 

o /Custom User Groups/SOAR Forwarding Connector/forwardSOAR 
o /Custom User Groups/SOAR Web User/apiSOAR 
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Rule 

• Change the “oldFileHash” value to a custom value. This needs to be the same as the “Key” value in the 
SOAR “Alert Source” covered later. The default value for “oldFileHash” is “change_me” and should be 
changed. 

 
 

 

Filters 

• “forwardSOAR” Filter 
o Change “Old File Hash” to the same value used in the “SOAR Integration Rule” Action. The 

default value for “oldFileHash” is “change_me” and should be changed. 
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Active List 

• This Active List is used by the “SOAR Integration Rule” and contains the correlation rule names that will 
be forwarded from ESM to SOAR. 

• The default includes rules based on the ESM Default Content, with rules based on TIP (Threat 
Intelligence Platform) and MITRE ATT&CK/STM (Security Threat Monitoring) content. 

• Modify this Active List with Rules based on you use cases. 

 
 
  

https://marketplace.microfocus.com/arcsight/content/esm-default-content
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Install the ArcSight Platform 
Next, install the ArcSight Platform. 

Master and Worker 

• With the CentOS 7.9 Minimal installations, we will need to run the following commands on the Master 
and Worker nodes. 
 
yum install chrony unzip -y 
systemctl enable chronyd 
systemctl start chronyd 
chronyc tracking 

yaml 

• Create /root/soar.yaml on the Master node. A screenshot of the yaml file is provided here and the file is 
provided at the end of this guide. In the yaml, we’re specifying the “pod-cidr” and “service-cidr” IP 
address ranges. These ranges must not be used elsewhere in the network where this cluster is operating 
and must not overlap. The default ranges are: pod-cidr: 172.16.0.0/16; service-cidr: 172.17.17.0/24. 
ArcMC Fusion will also be installed and is used to manage your ArcSight deployment. For more details 
on yaml file settings, please see the ArcSight Documentation site and the “install-config-doc.yaml” file in 
the “arcsight-platform-installer-22.1.0.16.zip” file. 
 

 
 
  

https://www.microfocus.com/documentation/arcsight/
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preinstall/install/postinstall 

• Upload the following files to /opt/installers/22.1 on the Master node. 
/opt/installers/22.1/arcsight-platform-installer-22.1.0.16.zip 
/opt/installers/22.1/arcsight-installer-metadata-22.1.0.37.tar 
/opt/installers/22.1/fusion-1.5.0.37.tar 
/opt/installers/22.1/esm-7.6.0.37.tar 

 
• On the Master node, run the following commands to unzip the ArcSight Platform Installer and place the 

metadata and images in the proper directories. 
 
cd /opt/installers/22.1/ 
unzip ./arcsight-platform-installer-22.1.0.16.zip 
mv ./arcsight-installer-metadata-22.1.0.37.tar /opt/installers/22.1/arcsight-platform-installer-
22.1.0.16/metadata/ 
mv ./fusion-1.5.0.37.tar /opt/installers/22.1/arcsight-platform-installer-22.1.0.16 /images/ 
mv ./esm-7.6.0.37.tar /opt/installers/22.1/arcsight-platform-installer-22.1.0.16 /images/ 
cd arcsight-platform-installer-22.1.0.16/ 
 

• Run the “arcsight-install” command and select “preinstall.” This installs any missing operating system 
package dependencies, runs checks on all hosts and reports if they meet the requirements, and modifies 
the configuration of all hosts so each host meets the required system configuration for the components 
that will be installed. 
 
./arcsight-install --config /root/soar.yaml 
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• Run the “arcsight-install” command a second time and select “install” to install the ArcSight Suite. 
 
./arcsight-install --config /root/soar.yaml 
 

 
 

• Once the install has completed, you’ll see this message. Logout and log back into Linux on the Master 
node, run the following command, and look at the “STATUS” of the pods. Once all pods are in either a 
“Running” or “Completed” status, you can proceed to the next step. 
 
logout/login on the Master node 
kubectl get pods -A 
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• Run the “arcsight-install” command a final time and select “postinstall” to run post-installation 
configurations. 

o If you see the following errors, logout/login on the Master node and run the command again. 
 ./hotfix.sh: line 66: jq: command not found 
 exit status 1 

 
./arcsight-install --config /root/soar.yaml 
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Create the first System Admin account 

• Login to the Fusion interface, create the first System Admin account, and login as that user. 
 
https://master.arcsight.example.com/ 
 

 
 

Login to the ITOM Management Portal 

• Login to the ITOM Management Portal using “admin” and the “CDF administrator password” you 
specified during the “install” phase. 
 
https://master.arcsight.example.com:5443/ 
 

 

  

https://master.arcsight.example.com/
https://master.arcsight.example.com:5443/
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License 

• Go to the ITOM Management Portal: https://master.arcsight.example.com:5443/ 
o Click “Deployment” -> “Reconfigure” -> “Fusion” 

 

 
 

o Use ESM License: Toggle to the right to turn this on 
o ESM URL: https://esm.arcsight.example.com:8443 
o ESM Username: admin 
o ESM Password:  

 

 
 

o Wait for the “soar-web-app” pod to restart. 
 
kubectl get pods -A | grep soar-web-app 

 

ArcSight ESM Host Configuration 

• Go to the ITOM Management Portal: https://master.arcsight.example.com:5443/ 
o Click “Deployment” -> “Reconfigure” -> “ESM” 

 ESM Host: esm.arcsight.example.com 
 ESM Port: 8443 

 

 
 
  

https://master.arcsight.example.com:5443/
https://esm.arcsight.example.com:8443/
https://master.arcsight.example.com:5443/
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Configure SOAR 
Next, configure SOAR in the Fusion interface (Respond -> Configuration). 

 

Parameters 

 
 

• “ArcSightListenerEnabled” and “ArcSightAutoEnrichEnabled” 
o Search for “arcsight” in the upper right and find the ArcSight settings. 
o “ArcSightListenerEnabled” needs to be enabled by clicking on “Value.” 
o “ArcSightAutoEnrichEnabled” needs to be enabled by clicking on “Value.” 
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Credentials 

 
 
Create a new “Credential” for the ESM “Web User” user that you created earlier. 

• Click “Create Credential” 
o Type: Internal Credential 
o Name: ESM 
o Username: apiSOAR 
o Password: change_me 
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Alert Source 

 
 
Create a new “Alert Source.” 

• Click “Create Alert Source Configuration” 
o Name: ESM 
o Type: Micro Focus ArcSight ESM 
o Address: https://esm.arcsight.example.com:8443 
o Key: change_me 

 Use the same value as the “oldFileHash” Set Event Field Action   
in the “SOAR Integration Rule” 

• Credential: ESM 
• Trust Invalid SSL Certificates: Checked 
• Click “Test” and “Save” 

 

 
 

 
 

  

https://esm.arcsight.example.com:8443/
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Install the Forwarding Connector 
The Forwarding Connector can be installed anywhere and does not have to be installed on the ESM 
Manager. Once the Forwarding Connector is installed, start it. 

Source Manager 

• Host Name: esm.arcsight.example.com 
• Port: 8443 
• User Name: forwardSOAR 
• Password: change_me 

Destination 

• Type: CEF Syslog 
• Ip/Host: master.arcsight.example.com 
• Port: 32200 
• Protocol: Raw TCP 
• Forwarder: False 
• CEF Version: 0.1 
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Troubleshooting 
Use the following resources to troubleshoot the SOAR and ESM integration. 

“forwardSOAR” Active Channel 

• This Active Channel will show all correlation events that the Forwarding Connector is sending to SOAR. 
 

 

 

“cdf-logsf” 

• The “cdf-logsf” alias will stream pod and container logs. Select the “arcsight” namespace, the “soar-
web-app” pod, and “soar-web-app” container. 
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“soar-web-app” Pod Errors 

• Pre validation failed. No active license found! No Recon, ESM or Intelligence license features found 
o These messages indicates that a license has not been setup or applied. 

• Your license does not allow for this operation 
o This message indicates an issue with the “soar-web-app” pod connecting to ESM to check 

licensing. If you see a “Host is unreachable” message, this indicates communication issues to 
ESM. 

• Key at Alert Source Configuration ('change_me') mismatched. Alert rejected. 
o This indicates an issue with the “Key” in the “Alert Source” configuration parameter. In the log, 

we can see that the value being sent from the Forwarding Connector is “change_me” but the 
“Alert Source” may not have the same value. 

• Key at Alert Source Configuration ('null') mismatched. Alert rejected. 
o You’ll see this with Forwarding Connector status messages that are automatically sent to the 

destination. These don’t have the “oldFileHash” event field set, so the connection is refused. 
“key (‘null’)” means that the “oldFileHash” event field is empty. These won’t cause any issues 
with the ESM and SOAR integration and can be ignored. 
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Enabling SSO with ESM 
Fusion allows you to import and integrate users from ESM. With single sign-on (SSO) supported 
between Fusion and ESM, users can easily access the ArcSight Console, ESM Command Center, and 
Fusion with the same login. 

Manager 

• Login as user ”arcsight“ on ESM and run “managersetup.” Step through the options and select “OSP 
Client Only Authentication” and click “Yes.” 
 
cd /opt/arcsight/manager/bin/ 
./arcsight managersetup 
 

 
 

 
 

• Configure the “External OSP Server” and click “Yes” to trust the server’s certificate. 
 
OSP Server Host:Port: master.arcsight.example.com:443 
Tenant Name for OSP: default 
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• Stop and Start the Manager. 
 
/etc/init.d/arcsight_services stop manager 
/etc/init.d/arcsight_services start manager 
 

 

Users 

• In the ESM Console, modify users and add full email address entries for the “External User ID” and “E-
mail” fields. 
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User Import 

• In the Fusion interface, click “Admin” -> “Users and Groups” -> “Import Users” and complete the “Import 
Users & Groups from ESM” form. 
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• Review the results of the user import. 
 

 
 

• For each imported user, click on “Reset Password” to set their initial password for the Fusion interface.  
 

 

Console 

• On the Master node, run the following commands to write the ArcSight Platform certificate to a file. If 
you see the following error after running the first command, please logout and log back into Linux: 
“K8S_HOME not set. If running on fresh installation, please use new shell session.” If you did not see this 
message, then run the second command. Open “master.crt” with a text editor and verify it is a valid 
certificate file like the screenshot. 
 
/opt/arcsight/kubernetes/scripts/cdf-updateRE.sh > /root/master.crt 
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• Download “master.crt” to the host where your ArcSight Console is installed. Open the Key Tool GUI by 
running “arcsight keytoolgui” from the “\Console\current\bin” directory. Open the “cacerts” file under 
the “\Console\current\jre\lib\security” directory (the default password for the “cacerts” file is 
“changeit”). Click “Tools” -> “Import Trusted Certificate” and select the “master.crt” file. Click “OK” -> 
“OK” -> “Yes” to accept the certificate as trusted and add this certificate. Click “File” -> “Save KeyStore” 
to save and “File” -> “Exit” to exit the Key Tool GUI. 
 
cd c:\arcsight\Console\current\bin 
arcsight keytoolgui 
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• Run “arcsight consolesetup” and step through the options. Select “OSP Client Only Authentication” and 
click “Yes.” 
 

 
 

• Open the ArcSight Console and click “OSP Client Login.” This will open a browser and prompt you to 
login to Fusion. Use an account you imported, and the ArcSight Console will open. 
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MITRE ATT&CK 
The MITRE ATT&CK integration in SOAR triggers off correlation events from ESM Default Content that 
have the “deviceCustomString6” field set to the Technique/Sub-Technique ID. There is nothing that 
needs to be configured in SOAR for the MITRE ATT&CK integration to work. In the Fusion interface, on 
the right pane of a Case, you’ll see a link to the Technique/Sub-Technique details and a like to the 
MITRE ATT&CK site. 

 

 
 

 
 

 

https://marketplace.microfocus.com/arcsight/content/esm-default-content
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MISP (Malware Information Sharing Platform) 
ArcSight SOAR can use a MISP instance to enrich Cases. In your MISP instance, you’ll need to setup an 
“Authentication Key” for SOAR to connect to MISP using the REST API. 

MISP “Authentication Key” 

On your MISP instance, generate an “Authentication Key.” This will be the same process if you’re using 
the CIRCL MISP Community instance or your own MISP instance. 

• Click “Home” -> “Automation” and click on “here” to manage your API keys. 
• Click “Auth keys” -> “Add authentication key.” 
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Credential 

 
 
Create a new “Credential.” 

• Click “Create Credential” 
o Type: Internal Credential 
o Name: MISP 
o Username: Leave this blank 
o Password: Leave this blank 
o Private Key: This is the “Authentication Key” from your MISP instance. 
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Integration 

 
 
Create a new “Integration.” 

• Click “Create Integration” 
o Name: MISP 
o Type: MISP 
o Address: https://misppriv.circl.lu/ 

 If you are using your own MISP instance, enter that URL here. 
o Credential: MISP 
o Trust Invalid SSL Certificates:  

 If you are using your own MISP instance with self-signed certificates, click this. This is not 
needed if using the CIRCL MISP Community instance. 

o Click “Save” 
o Click “Edit” 
o Click “Test” 

 

 
 

 
 

• To use the MISP integration, in an open Case, first click on “Enrich.” In “Launch Enrichment Plugin,” you 
can search for “misp” in the “Filter” or you can select “Threat Intelligence” -> “MISP” and select the type 
of enrichment based on the Scope Item (IP/URL/File). 
 

https://misppriv.circl.lu/
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Stopping and Starting the ArcSight Platform 
Use the following commands to stop and start the ArcSight Platform nodes. 

Stopping the ArcSight Platform 

• On the Worker node, run the following commands and select “y” for each. Once this has completed, run 
the same commands on the Master node. 
 
kube-stop.sh 
kubelet-umount-action.sh 
 

 

Starting the ArcSight Platform 

• The Master node will automatically start-up on boot. The Worker node will not automatically start-up on 
boot, and you’ll see pods in a ”Pending” status when you run the “kubectl get pods -A” command. Run 
“kube-start.sh” on the Worker node and wait several minutes for all pods to get in the “Running” status. 
 
kubectl get pods -A 
kube-start.sh 
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soar.yaml 
 
cluster: 
  allow-worker-on-master: false 
  master-api-ssl-port: 7443 
  master-nodes: 
    - hostname: master.arcsight.example.com 
      username: root 
      node-size: medium 
  pod-cidr: 192.168.0.0/16 
  service-cidr: 10.30.78.0/24 
  worker-nodes: 
    - hostname: worker.arcsight.example.com 
      username: root 
      labels: [fusion] 
      node-size: medium 
     
suite: 
  products: [fusion, esm] 
  config-params: 
    vertica-enable: false 
    arcmc-generator-id-start: 1 
    arcmc-generator-id-end: 16383 
    arcmc-generator-id-enable: true 
 
nfs: 
  node: 
    hostname: master.arcsight.example.com 
    username: root 
  type: new 
  root-folder: /opt/arcsight-nfs 
  uid: 1999 
  gid: 1999 
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BIND Files 
 

/etc/named.conf 
options { 
 listen-on port 53 { any; }; 
# listen-on-v6 port 53 { ::1; }; 
  forwarders { 10.10.2.254; }; 
 directory  "/var/named"; 
 dump-file  "/var/named/data/cache_dump.db"; 
 statistics-file "/var/named/data/named_stats.txt"; 
 memstatistics-file "/var/named/data/named_mem_stats.txt"; 
 recursing-file  "/var/named/data/named.recursing"; 
 secroots-file   "/var/named/data/named.secroots"; 
 allow-query     { any; }; 
 
 recursion yes; 
 
 dnssec-enable no; 
 dnssec-validation no; 
 
 /* Path to ISC DLV key */ 
 bindkeys-file "/etc/named.root.key"; 
 
 managed-keys-directory "/var/named/dynamic"; 
 
 pid-file "/run/named/named.pid"; 
 session-keyfile "/run/named/session.key"; 
}; 
 
logging { 
        channel default_debug { 
                file "data/named.run"; 
                severity dynamic; 
        }; 
}; 
 
zone "." IN { 
 type hint; 
 file "named.ca"; 
}; 
 
include "/etc/named.rfc1912.zones"; 
include "/etc/named.root.key"; 
include "/etc/named/named.conf.local"; 
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/etc/named/named.conf.local 
zone "arcsight.example.com" IN { 
type master; 
file "/etc/named/zones/arcsight.example.com"; 
allow-transfer { none; }; 
}; 
zone "2.10.10.in-addr.arpa" IN { 
type master; 
file "/etc/named/zones/2.10.10.in-addr.arpa"; 
allow-transfer { none; }; 
}; 
 

/etc/named/zones/arcsight.example.com 
$TTL 3H 
@ IN SOA master.arcsight.example.com hostmaster.arcsight.example.com. ( 
0 ; serial 
3H ; refresh 
1H ; retry 
1W ; expire 
3H ) ; minimum 
@ IN NS master.arcsight.example.com. 
master IN A 10.10.2.1 
worker IN A 10.10.2.2 
esm IN A 10.10.2.75 
forward IN A 10.10.2.82 
 

/etc/named/zones/2.10.10.in-addr.arpa 
$TTL 3H 
@ IN SOA master.arcsight.example.com hostmaster.arcsight.example.com. ( 
0 ; serial 
3H ; refresh 
1H ; retry 
1W ; expire 
3H ) ; minimum 
@ IN NS master.arcsight.example.com. 
1 IN PTR master.arcsight.example.com. 
2 IN PTR worker.arcsight.example.com. 
75 IN PTR esm.arcsight.example.com. 
82 IN PTR forward.arcsight.example.com. 
 

Company Details 
Company name: Micro Focus International plc 
Place of registration: England and Wales 
Registered number: 5134647 
Registered address: The Lawn, 22-30 Old Bath Road, Berkshire, RG14 1Q 
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