This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Looking for a creative solution - AcuToWeb?

We have what is probably a short term problem - but it's a BIG problem.

We have a graphical application coded in AcuCobol (oops - Extend - showing my age there!). It launches automatically when the Windows system starts. This is important.

And the second critical requirement is, we need to be able to sign into the system remotely and interact with the program. We currently do this with Remote Desktop.

This is easy under Windows desktop (10 & 11) and in the past it was doable on Windows Server. But it's getting harder and harder to accomplish in later Windows Server versions, and in WS2019 it seems impossible. We have not been able to find a way to make the program (1) launch automatically when the server boots, (2) with a graphical UI, and (3) allow us to access & interact with it remotely.

Of course we could refactor the application to separate the UI and the rest of the program, but that is more work than we are willing to take on right now. And really the perfect solution would be to allow remote access via web browser, not RDP.

It seems like AcuToWeb almost does this: it allows a GUI AcuCobol program to run on one system, and access it from any other system via browser. That would be a perfect solution except the program does not start until one connects via AcuToWeb.

If we could get the program to launch from eg Task Manager, and then run within the AcuToWeb architecture so we could access it remotely, that would be perfect. And WS would allow it because it's not interacting with the desktop/console. 

Is there a way?

(AFAIK it would not be possible to launch the web browser with the AcuToWeb URL on boot, because that accesses the Desktop, and thats the sort of thing WS2019 does not support)

Many thanks in advance for any answers, hints, or tips. Or even a definite "that cannot be done".

Tags:

Parents Reply Children
  • Thank you so much for responding!

    Yes I have seen that link, and I just re-read it. But maybe I have been misunderstanding it. I think it allows a user to login without entering their credentials, but it does not cause the login to occur automatically when the server boots. Am I wrong?

    Your home automation - does that have a user interface? Does the whole thing really start automatically when the server boots? And then are you able to interact with that UI when you actually login?

  • I just realized - at that link you gave, the very last line is:

    • You can use the Sysinternals tool AutoLogon to enable this functionality easier. This tool also helps you to use an encrypted version of password.

    And that is the tool we have been using. It worked in previous versions of Windows Server, but not in 2019.

  • Yes, my Windows Server 2016 *did* automatically log in, creating a desktop session after a reboot that I could just connect to with RDP at a later time. I vaguely remember using AutoLogon to set this up.

    While I'm still currently running Windows Server 2016, I did a complete re-install of the server operating system maybe 3-4 years ago. The home automation software (Home Control Assistant) now has a client/server version so I didn't have to set up automatic login again at that point and that was the only reason I had to log in. Before that, I do now remember using AutoLogon and creating a scheduled user task to launch the desktop program after automatic logon (it needed admin privileges so I couldn't just put it into the start folder). Unfortunately, those are all the details that I can remember.

    If Windows Server 2019 broke this, then Microsoft needs to update their page.

    I don't have any experience with server 2019 or 2022 other than a test platform, so I'm not going to be of much more help.

  • Thanks. I followed the procedure on that web page, and it works - it effects an automatical (that was a typo but I'll leave it) login when the server reboots. I just can't get it to start my GUI app. I have tried several different things in the Task Scheduler setup, most recently a 2 minute delay after login.

    I am sure it would start if it didn't have a UI - which brings us back to my original question.

    I also just investigated a 3rd party program that claims to solve this problem "AlwaysUp". But after some Q&A they said the app will run, but it will not be visible on the screen, and we won't be able to interact with it via Remote Desktop or anything else.

    Thanks again.