Communication Socket Error

Hi Everyone,

Were having a major issue with AcuThinclient where we are getting a number of communication Socket error.

We have setup a remote datacentre to host all our applications in the cloud and when we tried to use this product, we are getting this error and then the product completely shuts off.

We do not have a very stable internet connection and this is the only ISP around our current location so were stuck with them. We need to have some way to have some kind of keep alive session with the AcuThin-Client so if there is a slight disconnect, it doesn't drop the whole connection. A good example of this of course is Remote Desktop.

Somone had noted that we could use RDP locally to the Datacentre and access thinclient that way however having a machine just for this purpose isn't practical and a waste of system resources.

Does anyone know any alternate solutions or suggestions that can help us avoid this error?

Thanks,

jjjj12212

  • Have you experimented with TC_CHECK_ALIVE_INTERVAL ?

    This variable applies only in a thin client environment. Use it to specify how long the runtime should wait (in seconds) for an inactive client (a "dead" acuthin) before exiting the server runtime process. If you enter a value of "60", the runtime checks for client activity for 60 seconds. Client activity includes regular client user interaction or "ping" messages sent automatically from the client to the server. If no client activity is detected during the specified interval, the server runtime process exits. Valid values range from 1 to 32767. Set this variable to "0" to disable client checking. The default value is "300" (5 minutes).

  • Hi shjerpe,

    our current setup is the following:

    TC-CHECK-ALIVE-INTERVAL 30000

    TC-SERVER-TIMEOUT 30000

    If we set this to 0, would this resolve the issue?

  • sorry, I mean if we setup as

    TC-CHECK-ALIVE-INTERVAL 0

    TC-SERVER-TIMEOUT 30000

    would this resolve the issue?

  • sorry, I mean if we setup as

    TC-CHECK-ALIVE-INTERVAL 0

    TC-SERVER-TIMEOUT 30000

    would this resolve the issue?

  • try

    TC-CHECK-ALIVE-INTERVAL 3000

    TC-SERVER-TIMEOUT 30000

  • unfortinately, this is what we have been trying however we are still having this issue.

  • Verified Answer

    Let me know what version you are using. Also, if you using 9.2.0 or newer try this:

    Use runtime configuration variable, AGS_RETRY_COUNT, was created.  The

    default value is 1000 (retries).  Note that if for some reason the runtime

    ends up doing more than 1000 retries it will close the socket.

    You can use AGS_BLOCK_SLEEP_TIME in addition to AGS_RETRY_COUNT but try

    not setting AGS_BLOCK_SLEEP_TIME to start with so it will use the defaults:

       AGS_RETRY_COUNT 1000 (retry attempts before closing socket)

       AGS_BLOCK_SLEEP_TIME 10 (millisecond delay between retries)

    This way if the runtime has to do many retries it will only be sleeping

    10 milliseconds between them.  For example, if the runtime had to do

    100 retries before it was successful in transmitting the data:

    Retries AGS_BLOCK_SLEEP_TIME Total Sleep Time

    ------- -------------------- ----------------

    100     10 milliseconds      1.6 seconds

    100     100 milliseconds     16 seconds

    100     1000 milliseconds    1.6 minutes

    100     5000 milliseconds    8.3 minutes

    So if you have AGS_BLOCK_SLEEP_TIME set higher than 10 and you are

    experiencing long delays try setting AGS_BLOCK_SLEEP_TIME to a smaller value.