Acucobol Lento al tener varios usuarios conectados.

Hola a todos!

uso Acucobol. pero ultimamente con las plataformas de windows 8.1 y Server 2012 he notado que la lectura secuencia de archivos VISIO es muy lenta tanto que el usuario se desespera en la operación. ALGUIEN TIENE UNA SOLUCIÓN PARA ESTO?

  • ¿Está utilizando una unidad asignada al servidor de Windows 2012? ¿Has probado las técnicas de bloqueo oportunistas discutidos en el foro y en el wiki? ¿Es la protección contra virus en Windows 2012 o apagado?

  • Hola!

    Si estoy usando una unidad asignada

    Si la hice el procedimiento de bloqueo oportunista

    No tengo ningún antivirus.

    En este momento estoy regresando el servidor a au estado de fabrica para iniciar nuevamente con todas las pruebas, precisamente pensando en que algo haya hecho mal.

    Lo que he estado notando es que el servidor retiene por mucho tiempo los archivo abiertos, es decir en la consola de monitor de recuros, aparecen por mucho tiempo inclusive aun despues de haber cerrado la aplicacion el runtime y sus dll quedan bloqueados de forma permanente.

    Uno tiene que cerrar manualmente los recursos que quedaron bloqueados.

    las pruebas se están haciendo en maquinas virtuales.

  • Hola!

    Si estoy usando una unidad asignada

    Si la hice el procedimiento de bloqueo oportunista

    No tengo ningún antivirus.

    En este momento estoy regresando el servidor a au estado de fabrica para iniciar nuevamente con todas las pruebas, precisamente pensando en que algo haya hecho mal.

    Lo que he estado notando es que el servidor retiene por mucho tiempo los archivo abiertos, es decir en la consola de monitor de recuros, aparecen por mucho tiempo inclusive aun despues de haber cerrado la aplicacion el runtime y sus dll quedan bloqueados de forma permanente.

    Uno tiene que cerrar manualmente los recursos que quedaron bloqueados.

    las pruebas se están haciendo en maquinas virtuales.

  • Hola a todos!

    Le presento el escenario espero que me puedan ayudar.

    Tengo una aplicación en AcuCobol 6.0 Que usa archivos planos indexados, dicha aplicación esta montada en un servidor Windows 2012 (Total mente actualizado), el sistema es usado por dos estaciones con Windows 8.1 pro También actualizado.

    resulta que mientras los dos clientes al entrar al sistema no tiene ningún problema, sin embargo cuando los usuario inician operacion agregando datos al sistema, el proceso lectura secuencial de archivos que se encuentran abiertos de (lectura/escritura) se torna demasiado lenta, tanto que la aplicación en su barra de títulos aparece (NO RESPONDE).

    He estado buscando información en los foros respecto a este problema con algunos otros lenguajes me he encontrado que modifican modifican el registro del sistema tanto al cliente como al servidor des habilitando "Opportunistic Locking"

    Dejo el registro de lo que Modifique.

    Disabling Oplocks on Windows Client PCs

    To disable oplocks on a Windows client PC (a Windows PC that accesses an embedded database table hosted on another PC), change or add the following Registry values:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MRXSmb\Parameters OplocksDisabled = 1

    Disabling Oplocks on Windows Servers

    To disable oplocks on a Windows server (a Windows PC that hosts an embedded database table accessed from another PC), change or add the following Registry values:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters EnableOplocks = 0

    Hasta el momento he intentado deshabilitar el SMB2 y solo deja SMB1 (En el entendido que en widnows XP y Server 2003 funciona excelentemente) tanto del Windows Server 2012 y Windows 8.1 Pro, causando que funcione todavía mas lento el proceso de acceso a datos aun sin tener concurrencia, es decir trabajando solo uno de los clientes.

    Disabling Oplocks on SMB2 and SMB3

    Oplocks cannot be turned off for SMB2 and SMB3. You can disable SMB2 and SMB3 themselves, how to do so is documented by Microsoft in Knowledge Base article 2696547.

    According to that article, SMB2 and SMB3 can be disabled on Windows operating systems that support these.

    To disable SMB2 and SMB3 on a Windows Vista, 7, 8, Server 2008 or Server 2012 PC hosting embedded database tables, change or add the following Registry value:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters SMB2 = 0

    Once SMB2 and SMB3 are disabled, SMB1 should be re-enabled to be used again and the methods described above applied to disable oplocks for SMB1.

    To re-enable SMB1 on a Windows Vista, 7, 8, Server 2008 or Server 2012 PC hosting embedded database tables, change or add the following Registry value:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters SMB1 = 1

    Alguna otra sugerencia o comentario, Gracias a todos por leerlo.

  • Resolvimos (esperamos!) Mediante el establecimiento de clave de registro HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \ TSFairShare \ Disk

    EnableFairShare a 0

    Mira esto:

    social.technet.microsoft.com/.../rd-session-host-slows-down-program