AcuToWeb does not start correctly in 10.3.0 but started OK in 10.2.1

0 Likes

PROBLEM

When trying to start AcuToWeb on Linux a message appears saying that it has started ‘AcuToWeb Gateway Started (PID: 18887).’

When checking the status of AcuToWeb it says that it is not running ‘AcuToWeb Gateway not running (invalid PID file).’

Checking the gateway.out shows the error message:

… ImportError: cannot import name certificate_transparency

 

SOLUTION

This can be caused by the version of GCC on the host machine being too low or by a missing dependency.

To check the version of GCC on the host machine, run the following command:

gcc –version

Sample output from CentOS:

gcc (GCC) 4.8.5 20150623 (Red Hat 4.8.5-36)

Starting in 10.3.0 the minimum version of GCC required on Linux is 4.8.0

If the version of GCC on the host machine is below this requirement then it will need to be updated according to your OS.

 

To check if the issue is caused by a missing dependency, run the following command in the acutoweb directory of the Acu installation:

ldd ./Python2.7/lib/python2.7/site-packages/cffi-1.12.3-py2.7-linux-x86_64.egg/_cffi_backend.so

If any of the dependencies are missing for example ‘libgcc_s.so.1 => not found’ they will need to be installed:

yum provides libgcc_s.so.1 libgcc-4.8.5-39.el7.i686 : GCC version 4.8 shared support library Repo : base Matched from: Provides : libgcc_s.so.1 yum install libgcc-4.8.5-39.el7.i686

Labels:

HowTo
Tip from Support
Comment List
Related
Recommended