MAX_FILES Configuration Does Not Resolve 94,10

0 Likes

The ACUCOBOL-GT Runtime halts with file status 94,10 even after increasing MAX_FILES to the maximum.

Problem:

When executing a particular application, the ACUCOBOL-GT Runtime halts with file status 94,10, Too many files open by the current process. The runtime configuration MAX_FILES was increased to its maximum of 32767; however the same error occurs. The application opens less than 50 files which reside on a separate server and are accessed via AcuServer.

Resolution:

The MAX_FILES setting was made in the Runtime configuration file. The files are being served by AcuServer which is governed by a MAX_FILES setting of its own. MAX_FILES must be set for both the Runtime and AcuServer.

The solution is to stop AcuServer, add a MAX_FILES setting in the a_srvcfg configuration file, and then restart AcuServer.

As noted in the MAX_FILES documentation, the operating system may limit the number of files open per process. You might need to also adjust the appropriate kernel parameter.

Old KB# 14095
Comment List
Anonymous
Related Discussions
Recommended