How to avoid prompt when killing AcuConnect

0 Likes

Problem:

When shutting down the AcuConnect service the user receives the following prompt to the kill command:

unix1:/opt/acucorp/800/bin # ./acurcl -kill

Shutting down AcuConnect on: unix1

There are 0 child processes on: unix1

Do you really want to shutdown AcuConnect No?

This is not a issue when running interactively, but when running from a script the prompt can be problematic. How can the prompt be avoided when running a script?

Resolution:

AcuConnect User's Guide

Version 8.0

Chapter 8: Managing the System > 8.2 Managing the System: UNIX > 8.2.1 The acurcl Command >

8.2.1.6 acurcl -kill

Unless the "-f" option is specified, AcuConnect prompts for confirmation before the halt action is executed.

The following is an example of using the "-f" option to halt AcuConnect.

Example:

unix1:/opt/acucorp/800/bin # ./acurcl -kill -f

Shutting down AcuConnect on: unix1

There are 0 child processes on: unix1

AcuConnect is now stopped

Old KB# 2812
Comment List
Anonymous
Related Discussions
Recommended