Printing - Escape sequences are being ignored when printing on Windows

0 Likes

Problem:

Programs that have been running under AIX and handle all the printer settings including forms feed using escape sequences, have been moved to a Windows platform. Is there anything special that needs to be done to enable form feeds with Windows printers?

Resolution:

To control the format of the printout using embedded control codes, simply assign the print file to "-P SPOOLER-DIRECT" or to "-Q <printername>" using the "DIRECT=ON" option.

For example, to assign the print job "PRINTER1" to the spooler and retain direct control over formatting, enter the following line in the COBOL configuration file ("CBLCONFI"):

PRINTER1  -P  SPOOLER-DIRECT

Or, use the following command to assign PRINTER1 to the spooler for printing to a specific printer while retaining direct formatting control:

PRINTER1 -Q printername;DIRECT=ON

Both of these methods cause the print job to be sent to the printer via the Windows spooler, but the program does not use the spooler to format the pages.

When using these options embedded control codes to handle formatting must be used (as would be done when running on UNIX and using the UNIX spooler).

Old KB# 2700
Comment List
Anonymous
Related Discussions
Recommended