ZMF Explorer: display build listing for a non LST library type returns compressed data

So far the ZMF explorer v2.0.0 has been working, but today (I think for the first time since I installed it) I tried to display the build listing for a component and got this message:

Error cannot open file:///c%3A/users/carstenm/ChangeMan/tempzmf/ChangeMan/PTCH001377/COBMAIN/COBMAIN.txt. Detail: File seems to be binary and cannot be opened as text undefined

  • I would suggest that whilst you are in VSCode, that you then open the file in Windows Explorer from that location and see what the contents actually look like. 

    The file content should be text job output, the result of a compilation but with the Print control characters stripped out. 

    Depending on what the file actually looks like will determine the next steps.

    For the package library type is this a HFS library type by any chance? 

    Sr R&D Manager, Mainframe Products

    Micro Focus

  • The listing is not for an HFS type, just a COBOL program. 

    This definitely worked at some point, but I don't remember exactly when.

    This is what the actual contents of the file look like:

     éøç sâ÷°QȞiàSjì*‚ ‘’Ðt4 ˖ߖ‰DYɕUýï/‘r<Wlß©úø*ðáxlR4Úà؎ 
    nä~!mk,À[ ȧLãé¿ƒk£ç†\o2€•}Š”’€Ø6q˜üðïbY€”*ý›lMO `î‰tE²:`ž||‡H ”£^$
    15DU/¢*åWÝ¡O¾¹Ö¿³ ·½K
    àyé¦kdÛÚ Âhíš;ksR>k
    ÂjŠc.‰ÍÇèfO,[ŒÆ­(çdⰝy­Ä·é`Á¾DE 최œŠßä„Nç+“µPÁð“</öc&D¢
    öƒ 9öçˆL<Ú¢µ˜ðþc~«eÇ’g‚ts€hµ—Žœ€Ç‚–»
    /I¢( Sä«Ì„ˆuOý䆢

  • We have recreated this problem internally. It occurs when using a library type other than LST for listings. This is an error in the REST service rather than specifically in the ZMF Explorer. I will open a Support ticket for this and we will create a hotfix for this problem against the service.

    Sr R&D Manager, Mainframe Products

    Micro Focus

  • Verified Answer

    ChangeMan ZMF hotfix ZMF8.2.6.011 is now published and available to address this problem.  

    Sr R&D Manager, Mainframe Products

    Micro Focus