org.omg.CORBA.OBJECT_NOT_EXIST: Permission denied: connect

Does anyone have suggestions on how to troubleshoot this issue?

I am running the VisiBroker OS Agent (8.5 SP8) locally. I'm trying to get it running for the first time on a new laptop. Many of us developers have run v8 versions locally for a couple of decades and it worked for me on my old laptop (with an older SP version). I have two CORBA services (I'll call DS and Messages) that I am also running locally. In the osfind, it will show both services as having successfully registered. Depending on the various incarnation of localaddr, sometimes VBconsole sees the registered objects. And other times, it can't connect to the OS agent.

Messages then tries to call DS and gets the following error:

org.omg.CORBA.OBJECT_NOT_EXIST: Permission denied: connect  vmcid: 0x56420000  minor code: 1  completed: No

I ran the osagent with options: "-v +l a". In the log file, I see that when the request comes in to call DS, the following is logged, which makes it seem as if a response is if things are working as expected:

==>> Wed Nov 8 12:13:53 2023, dsaclnt.C, 0, Inf
getProvider() Received <GetProvider> from client at
Host : <IP>
User : java
PID : -1339816031
CAddr :
VPort : 61940
CPort : 61940
Requesting for the following service:

==>> Wed Nov 8 12:13:53 2023, dsaclnt.C, 0, Dbg
getProvider() Service type <4>, Argument type <1>.

==>> Wed Nov 8 12:13:53 2023, dsaclnt.C, 0, Inf
getProvider() Replying that service is located at,
Address : <IP>
Port : 52970

Someone suggested adding a localaddr file into the \adm folder. I've tried probably a dozen different combinations for ethernet only or wireless only connection. Depending on setup, VB Console sometimes can't find the agent (while osfind always can). However, in all cases, Messages gets "Permission denied". Going back three months, I see no case of any of our almost two dozen CORBA applications in environments ever having logged this error.

Note that I do have some admin permission on this laptop.

Other things I've tried:

  • Moving installation folder under My Documents
  • Running OSAgent as Administrator
  • Running my IDE as Administrator. (I'm launching the services from my IDE as I have always done.)
  • Disabled (temporarily) all firewall settings
  • Reviewed the process in Windows Process Monitor.