This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Exception on right-click in Cobol perspective in MFED rel 7

Installed Micro Focus Enterprise Developer rel 7 with PU8. To have latest rel of eGit I used update software from Eclipse. Also had to update IDE from 4.16 to 4.23. When right-cliked I get a exception.  Any suggestion how to solve this issue? 

BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Framework arguments:  -feature com.microfocus.eclipse.edt.core.product -product org.eclipse.epp.package.jee.product
Command-line arguments:  -os win32 -ws win32 -arch x86_64 -feature com.microfocus.eclipse.edt.core.product -product org.eclipse.epp.package.jee.product

Wed May 25 09:41:25 CEST 2022
Unhandled event loop exception

java.lang.NoSuchMethodError: 'void org.eclipse.e4.ui.workbench.renderers.swt.MenuManagerShowProcessor.showPopup(org.eclipse.swt.widgets.Menu,, org.eclipse.jface.action.MenuManager)'
	at org.eclipse.e4.ui.workbench.renderers.swt.MenuManagerShowProcessor.ajc$privMethod$com_microfocus_eclipse_editor_aspects_e4_menumanager_MenuManagerShowProcessorAspect$org_eclipse_e4_ui_workbench_renderers_swt_MenuManagerShowProcessor$showPopup(
	at com.microfocus.eclipse.editor.aspects.e4.menumanager.MenuManagerShowProcessorAspect.ajc$around$com_microfocus_eclipse_editor_aspects_e4_menumanager_MenuManagerShowProcessorAspect$1$6e7de065(MenuManagerShowProcessorAspect.aj:104)
	at org.eclipse.e4.ui.workbench.renderers.swt.MenuManagerShowProcessor.menuAboutToShow(
	at org.eclipse.jface.internal.MenuManagerEventHelper.showEventPreHelper(
	at org.eclipse.jface.action.MenuManager.handleAboutToShow(
	at org.eclipse.jface.action.MenuManager$2.menuShown(
	at org.eclipse.swt.widgets.TypedListener.handleEvent(
	at org.eclipse.swt.widgets.EventTable.sendEvent(
	at org.eclipse.swt.widgets.Display.sendEvent(
	at org.eclipse.swt.widgets.Widget.sendEvent(
	at org.eclipse.swt.widgets.Widget.sendEvent(
	at org.eclipse.swt.widgets.Widget.sendEvent(
	at org.eclipse.swt.widgets.Control.WM_INITMENUPOPUP(
	at org.eclipse.swt.widgets.Control.windowProc(
	at org.eclipse.swt.widgets.Canvas.windowProc(
	at org.eclipse.swt.widgets.Decorations.windowProc(
	at org.eclipse.swt.widgets.Shell.windowProc(
	at org.eclipse.swt.widgets.Display.windowProc(
	at org.eclipse.swt.internal.win32.OS.TrackPopupMenu(Native Method)
	at org.eclipse.swt.widgets.Menu._setVisible(
	at org.eclipse.swt.widgets.Display.runPopups(
	at org.eclipse.swt.widgets.Display.readAndDispatch(
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(
	at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(
	at org.eclipse.ui.internal.Workbench.lambda$3(
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(
	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(
	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(
	at org.eclipse.ui.internal.ide.application.IDEApplication.start(
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(
	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(
	at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(
	at java.base/java.lang.reflect.Method.invoke(
	at org.eclipse.equinox.launcher.Main.invokeFramework(
	at org.eclipse.equinox.launcher.Main.basicRun(



Enterprise Developer
  • Hi, some questions to understand the situation more:

    -What did you have installed before and was it working then?
    -Was only PU8 installed, then you see this issue?
    -Where exactly do you right click, e.g. in the COBOL Explorer?

  • Hi,

    - upgrade from rel 6, pu16, to rel , pu8. It work before and after this upgrade.

    - Installed first rel 7 and then pu8, right-click worked in both git repositories and cobol explorer

    - then I upgraded git from 5.8 to 6.1. included in this upgrade was eclipse from 4.16 to 4.23

    - right-click in cobol explorer, cobol program. then nothing happened, check error log and found the error message. Same behavior in git repositories under git perspective. Right-click does not work

    - Tried to revert this upgrade, but no luck. Eclipse.exe file was deleted. Finally I reinstalled MFED. First rel 7, then pu8, current version of git is now 5.8 and eclipse is 4.16

  • Hi Sondre,

    In your Eclipse IDE > Window > Preferences > General > Startup and Shutdown > Check the list of plugins that are loaded. Do you see the  GIT plugin listed? If yes as a test uncheck those, apply the changes then try to recreate the issue. Is this issue still seen? This will help you determine if the GIT plugin is causing the problem, or not. Result?

    Also when the error is seen, what is recorded in the Eclipse .log file?

  • Hi, have had small vacation...

    This is the startup

    Tried to only update eclipse IDE

    Got  the same error. I think ver 7 is not compatible with latest ide

  • Hi Sondre,

    Hope you had a good vacation.

    Going back to what you wrote initially:
    Enterprise Developer rel 7 with PU8. To have latest rel of eGit I used update software from Eclipse. Also had to update IDE from 4.16 to 4.23. When right-clicked I get a exception.  Any suggestion how to solve this issue? 

    Can you share details of how you update the eGit part, e.g. where in Eclipse do you perform the update? Via the Help > Install New software?

    Where do you right click when the exception is seen? What part of the IDE or which button/view in Eclipse?

  • Hi,

    thanks, nice to have few days of.

    I have tried both ways for updating inside Eclipse, Help > Install New software and Help > Check for updates.

    I right click in a cobol program and a copybook. 



  • Hi Sondre,

    To get the latest release of eGit do you install any plugin or additional software into Eclipse? e.g. from URL:  I will try to replicate your issue, I just want to make sure I am using the same software a you.

  • Hi,

    sounds great to replicate it.  One of my attempts was only to upgrade from eclipse IDE 4.16 to 4.23. Se screenshot in a previous message. Same error.

    I did not explicit download from a URL, only used eclipse functions "Help > Install New software and Help > Check for updates"


  • Hi Sondre,

    I updated my Eclipse instance via "Help > > Check for updates" , it updated a quite a few components, after Eclipse restarted I try to right click in the editor and now see the same exception that you initially reported. So I can recreate the problem.

    Typically we would need a support case to assist you further, as this appears to be a possible product issue. Can I ask if you have a support account and can raise a case? If yes please let me know of the case number.  I could not locate your name in the support system. If you can confirm this  and/or share your account details (note not via this post, preferably via a private message as I recommend not to share this in a forum like this where other customers can see that) then I can raise a case on your behalf and get this issue reviewed by our developer team. Let me know what you prefer.

  • Hi Sondre, I think I have located your company's account in our support system, to confirm do you work with colleagues such as Rune and/or Bjørn ? If you can confirm that then I can raise a case on your behalf to get this actioned.

  • Verified Answer


    sounds great. Yes - I'm working with Rune B. and Bjørn A. in MMG / Møller Digital.

    If you create it, please let me now what the support number is.

    Thanks in advance



Reply Children
No Data