This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Getting file Open issue when program thru micro focus dialect

My program reading the sequential file (flat)  and writing the same thing into output file (flat). This one got executed when I tried with ZOS Enterprise Dialect.

However if I compiled thru Micro focus dialect getting incompatible issue and getting file status as 47.


We tried in Input and I-O modes, Getting same issue for both the modes.

Could you please help me out.




Enterprise Developer
  • Hi, I recommend you to check the following.

    See documentation URL:

    That shows:
    47 - A READ or START operation has been tried on a file not opened INPUT or I-O.

    I recommend you to review your code and adjust that if/as needed, e.g. open the file for INPUT or I-O, then confirm if the issue persists.

    If you require further assistance then I recommend you to consider raising a support case where an engineer can assist you.