Micro focus region refresh process taking too long

Dear Everyone,


We observed that micro focus region refresh is taking too long post upgrade i.e v5.0 Pu24 where as in v4.0 Pu14 it took less than 5 mins.

Here are the observations,

1) Region is started state within a minute after clicking the start tab/issuing the start command.

2) But all the allocated SEP's are in BUSY state with the process “CICS (Facility N/A Transition)” in ES monitor and control page for longer time (30 to 40 mins).

3) CPU% remains 100% until all SEP’s became IDEL state.

4) Server slow until all the process i.e “CICS (Facility N/A Transition) PIP2" are auto cleared up from ESMAC .

5) Multiple entries in the console log with following new message “ESFEV0328I Using native mutexes for thread locking” post upgrade.


Allocated SEP: 51
Admin SEP : 3

Can you please someone assist me to fix this performance issue.

Thanks,

  • Suggested Answer

    Hi Venkat, 


    Have all application modules and region related modules been recompiled tov5.0 Pu24? If not please check that, test again.

    When the SEP's are showing as busy you can navigate to the ESAMC > SEPs area, click on the trace button for one of the BUSY SEPs and check what events are occurring for that SEP/PID.  If that does not help you to understand what the SEPs are busy with or waiting for then I recommend you to raise a support case to seek further assistance, as this will likely require further detailed tracing analysis. Please consider to include a MFESDIAGS diagnostics collection from the time of when the issue is seen. You can download the MFESDIAGS support script from URL: marketplace.microfocus.com/.../mfesdiags