Micro Focus Enterprise Developer Unix Components 6.0 - Patch Update 13 - HTTP server failed to initialize, rc=6: CCITCP-0006E An invalid server or machine name was presented

Hello,

I have a problem when starting the mfds service on the version in question.

For a DR test we have replicated the production machine by performing the copy low-level disks (storage to storage)

when I try to start the mfds service the following error appears :

SM0001I Terminated (atexit).
HS0328E GETERROREX failed, rc = 3
HS0001S (cont) to CCITCP.
HS0001S HTTP server failed to initialize, rc=6: CCITCP-0006E An invalid server or machine name was presented
DF9046I /opt/ed60u3/etc/mfdsacfg.xml
DF9045I Saved XML config file
Process UID: mfserver

I attempted the following tests with negative results :

I verified and reinstalled the licences,
I verified the xml file settings between the DR server and the production server
I removed and reinstalled the product
I verified in the /etc/services file the presence of ports 86(tcp and udp) for mfcobol services


the mfds process starts only if I assign a port higher than 1024.

do you have any advice for me ?

thanks
Giuseppe

  • Suggested Answer

    Hi Giuseppe,

    Some questions:

    -Can you start other services ok, is it only mfds that gives a problem?
    -How are you starting the mfds service, which command is used?
    -How did you "remove and reinstalled the product", using the install process or deleting / copying files?
    -As you replicated the production machine by performing the copy low-level disks, do you copy permissions also? did you give the product files/mfds service permissions?
    -Does the account you try to start with have sufficient permissions?

    It appears this issue will likely require further investigation, therefore I I recommend you to consider raising a support case so that one of my colleagues can work via the case to provide help. You can include MFESDIAGS diagnostics and answers to the above to speed up troubleshooting.

  • Hi KimH

    Thank you for your reply, here is the answer to the questions.
    unfortunately the problem has not yet been solved,

    Hi Giuseppe,

    Some questions:

    -Can you start other services ok, is it only mfds that gives a problem? --> yes, only the mfds service has the problem

    -How are you starting the mfds service, which command is used? --> After setting the environment variables, I launch the command mfds &

    -How did you "remove and reinstalled the product", using the install process or deleting / copying files? --> I have, done various tests. deleted the folders and reinstalled.
    i also tried running sh to uninstall the product and the licence server.

    -As you replicated the production machine by performing the copy low-level disks, do you copy permissions also? did you give the product files/mfds service permissions? -->
    the system administrators say that the permissions are the same as on the production server.
    what do you mean by mfds permissions?
    it is launched as root, it fails when it tries to switch to the default user (the one indicated during installation)

    -Does the account you try to start with have sufficient permissions? -->
    is the same as the one used in production, we also tried increasing the user permissions


    It appears this issue will likely require further investigation, therefore I I recommend you to consider raising a support case so that one of my colleagues can work via the case to provide help. You can include MFESDIAGS diagnostics and answers to the above to speed up troubleshooting. -->

    thank you, we have opened a tk to support and provided logs with the truss command.

  • Suggested Answer

    Thank you, please continue to work via the support case for further help.

  • Hello

    Problem solved via Microfocus support.

    The problem was caused by a time-out during the bind step on port 86.
    On the advice of support I changed the parameter "hosts=local, bind" to "hosts=local, bind4" in the file (/etc/netsvc.conf).

    after the change the console started correctly.

    thanks
    Giuseppe

  • Suggested Answer

    Hi Giuseppe, thank you for your update, if this post is resolved please consider to mark as answered. Thanks.