Keyboard mapping the square brackets [ send a "cent" sign

Mainframe 3270 connection, using the IBM 101 keyboard mapping, when I press the left square brackets [ I get a "cent" sign, where is this mapped?  How do I make the bracket appear correctly.  Other emulators work fine, but having this issue with Extra?

Parents
  • Don Doty,

    As you suspected, you will need to remap the PC bracket keys, as the brackets are more of  a special (apl) kind of character on the host side.

    Here are some steps for that action.

     - From the EXTRA! session, select the Options\Settings\Keyboard Maps.

    - Edit the default map, EXTRA! Office (101 Key).ekm.

    - Double-click the cent key and change the properties.

    - Under Commands highlight Send Special Keys.

    - Under Keystrokes select the select the left bracket (will need to scroll down the list).

    - Click OK. Should now see the left bracket mapped to what was the cent key.

    - Repeat this process for the right bracket on the "|" key.

    - Save the modified keyboard map.

    Best Regards,

    Jeff B

Reply
  • Don Doty,

    As you suspected, you will need to remap the PC bracket keys, as the brackets are more of  a special (apl) kind of character on the host side.

    Here are some steps for that action.

     - From the EXTRA! session, select the Options\Settings\Keyboard Maps.

    - Edit the default map, EXTRA! Office (101 Key).ekm.

    - Double-click the cent key and change the properties.

    - Under Commands highlight Send Special Keys.

    - Under Keystrokes select the select the left bracket (will need to scroll down the list).

    - Click OK. Should now see the left bracket mapped to what was the cent key.

    - Repeat this process for the right bracket on the "|" key.

    - Save the modified keyboard map.

    Best Regards,

    Jeff B

Children