Keyboard mapping the square brackets [ send a "cent" sign

Mainframe 3270 connection, using the IBM 101 keyboard mapping, when I press the left square brackets [ I get a "cent" sign, where is this mapped?  How do I make the bracket appear correctly.  Other emulators work fine, but having this issue with Extra?

Parents
  • Don Doty,

    As you suspected, you will need to remap the PC bracket keys, as the brackets are more of  a special (apl) kind of character on the host side.

    Here are some steps for that action.

     - From the EXTRA! session, select the Options\Settings\Keyboard Maps.

    - Edit the default map, EXTRA! Office (101 Key).ekm.

    - Double-click the cent key and change the properties.

    - Under Commands highlight Send Special Keys.

    - Under Keystrokes select the select the left bracket (will need to scroll down the list).

    - Click OK. Should now see the left bracket mapped to what was the cent key.

    - Repeat this process for the right bracket on the "|" key.

    - Save the modified keyboard map.

    Best Regards,

    Jeff B

  • Ok, I might not have explained this correctly.  It's when I hit the [ bracket key, I want it show and send a [ bracket  on the screen, not the cent sign.  How do I ensure to actually send a [ bracket?  Key mappings shows that a [ bracket is correctly doing a "send keys" of a [ bracket, but it shows up as a cent sign.

  • Don Doty,

    If you have the keyboard mapping correctly changed to send the [ then when you type it, I would expect the screen to show a [. 

    Pressing the keys appears as

    If you find the data stream is still sending the other data to the host.  There could be an issue with the terminal type configuration on the host.  This would not be something that we could work through in the community as we would need network protocol traces to ensure the data stream is sending and receiving the correctly decoded information.  If you have active maintenance you can contact us at 800-688-3270 or email Support2@microfocus.com.

    Thanks,
    Jeff

  • I don't have that, this is my map?

    without Shift

    With Shift

    So, is this terminal type setting?

  • Hi Don Doty,

    As you note, the keyboard map has not been changed.  The instructions in the "Suggested Answer " above should change the key map to appear like the picture I shared above.  I don't think this has an affect, but your without shift and with shift captures appear to be reversed as the with shift will have the "Shift" key itself greyed out as it does in your without shift picture.

    Regards,

    Jeff B

  • Yeah, I don't actually have the product installed, and driving blind trying to help a 3rd party.  I'll get someone to check session settings and send me a screen shot, usually 3270 right, what do you have it set to...just curious, can you "break" your connection and make it so the brackets [ are actually sending something else, to get a better idea of what this issue might be?

Reply
  • Yeah, I don't actually have the product installed, and driving blind trying to help a 3rd party.  I'll get someone to check session settings and send me a screen shot, usually 3270 right, what do you have it set to...just curious, can you "break" your connection and make it so the brackets [ are actually sending something else, to get a better idea of what this issue might be?

Children
  • If you go into the host translation tables you could break this, but that would be an unusual situation.  When the keyboard performs a send key (which really means send the code for this terminal character) and that keystroke shows up in the terminal screen, that key should be what is sent to the host.  So if you see a [ on the screen you are sending that code to the host.

    Regards,

    Jeff B

  • I have other emulator's that work, Rumba/Passport, etc., and they have no problem sending bracket [, it's just with Extra so it's gotta be in the config somewhere, just need to know where to look?

  • Hello Don Doty,

    If you get the keyboard map changed with the instructions above Extra! will work just like Rumba and Passport.

    Regards,

    Jeff B.

  • The suggested answer doesn't work, I can't correct the title of this, but it should have said "Keyboard mapping the square bracket [ sends the 'cent' sign instead INCORRECTLY".  I have the [ bracket, the keyboard mapping shows that it's doing a SEND KEYS with [ bracket, it looks correct, however when I press the [ bracket, a cent sign shows up, this is incorrect, I don't want a cent sign, I want the [ bracket to show up.  Just like any other key, when I press the X, I want the X to show.  So, when I press the [ bracket, I want the [ bracket to show.  Other emulators do this correctly, but I can't get this to work correctly in Extra, how to fix?

  • Hi Don Doty,

    Please make sure the Keyboard Map that the user has selected is updated properly:

    As stated in the instructions above, you must choose select "Send Special Keys" and choose the bracket character from the dropdown list:

    Because this is a special key to the host, simply typing the bracket as a standard keystroke will not change the behavior of the key.  Standard "Send Keys" action with a bracket sends the same code as the cent sign.

    Regards,

    Jeff B.