This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

How can launch Rumba AS400 Display from command line which will show me the login screen so I can input my username and password?

We are working on a automated process which need launch Rumba AS400 from command line. We noticed there is an example like below:

RumbaPage.exe /Display:MFrame /Host:<destinationHost> /Port:<Destination Port>

but this command and arguments cannot bring the AS400 /TN5250 login screen let me input username and password

What should be the correct command arguments so I don't need select AS400 display from Rumba GUI? Then it can recognize the destination host and port from command line to launch Rumba until the login screen show up automatically?




  • By the way, we cannot use a pre saved session profile in this case either. because the end user is a temporary windows local user that is created just before a windows RDP session and then to be deleted when session done.

  • Suggested Answer

    Hi Alex Li,
    your approach looks good to me and it works in my test.
    I tested with RUMBA Desktop 10.1 using following command line.

    RumbaPage.exe /Display:as400 /Host:myas400hostname /Port:23

    The command starts an AS/400 Display Session to the provides hostname and will automatically connect the session.

    - What Rumba version are you using ?
    - Can you please describe the automation scenario ?
    - Are you using a third party tool for the automation ? 

    If the command line is not working you could use a simple Rumba Script to create a temporary Display session.

    'launchRUMBA.csf sample script

    Sub Main
    EMSetTN5250 "yourAS400",23, 2, "COLOR"   ' set a temp as400 display session
    EMStartSession "*","5250"
    EMConnect "5250"
    End Sub

    The following example show you how to use the script player command line options:

    VSP.exe launchRUMBA.csf

    hope it helps


  • Hello Andree,
    Thank you very much helping me on this issue.
    Yes, we use IBM Secret Server (same as Thycotic Secret Server) manage and store the iSeires credentials with login automation. when a person who need work on iSeries with AS400 Emulator, he need login to IBM Secret Server to checkout the credential. the checkout will not show the clear text password, but automatically launch an RDP session to a windows proxy server which in turn to launch Rumba AS400 display with target iSeries server connection and inject the credentials automatically.

    when I try your command with version 10.1 trial version, it does work! Thanks a lot. The only issue is the trial version will show the remaining days that need manually click OK

    However, in our current actual environment, we have a Rumba version 7.5.2, when I run the command below with WDDspPag.Bin, it shows a popup window asking to select as400 display. Looks it did not take the arguments:

    C:\Users\TEMP.COMBANK.006>"C:\Program Files (x86)\NetManage\RUMBA\system\WDDspPag.Bin" /Display:as400 /Host: /Port:23

    probably the Display argument is different? Can you help me how to make this program working to show the login screen with TN5250 (27rows) from command line?

    Thank you very much!

  • Hi Alex Li,
    not sure  but it think was not possible to pass the mentioned  parameters to  RUMBA version 7.5.2.
    Only the session profile can be passed, for as/400  the profile with the *.wda extension.
    Rumba 7.5.2 was released in 2008 supporting Windows XP , Vista and Windows 2000.
    You will encounter more issues with such an old version. I recommend an update to Rumba 10.1.

    If you need to pass the model type (27 rows) than I recommend to use a Rumba Script as described in my previous reply.

    You can pass the model type as a command line parameter.

    vsp.exe -vmodel=5 launchRUMBA2.csf

    model=5 is passesd to the script in order to start Rumba with 27 rows.

    Valid Device Types:
    2 -> 24 row x 80 col (Type = 3179)
    5 -> 27 row x 132 col  (Type = 3477)

    'launchRUMBA2.csf sample script

    Sub Main
      EMSetTN5250 "dekel","23", model, "COLOR"
      EMStartSession "*", "5250"
      EMConnect "5250"
    End Sub

    Not recommended but the script should work with Rumba7.5.2


  • Verified Answer

    Hello Andree,

    We would like take your recommendation to do upgrade, before upgrade, I wanted to try the latest version of v101. When I install it on a machine that does not have v7.5.2 installed, everything works fine. I can launch it from command line.

    But when I install it on a machine that have v7.5.2 installed (NetManager suite). looks it automatically removed some of the files of v7.5.2. When I launch the new Rumba AS400, it shows this error message:

    License Manager failed to validate license for this product from the following reason: Citrix/WTS license is required.

    Is this because of v7.5.2 installed or because I already installed the same trial download on another machine? Should I uninstall v7.5.2 before I install trial version of 10.1?

    Thanks a lot for your review and suggestions!


  • Suggested Answer

    Hi Alex,

    good to hear that RUMBA 10.1 works for you from the command line.
    RUMBA 10.1 is a more recent version of Rumba 7.5.2.
    You cannot run both versions in parallel. You should remove the old version first. 
    The provided  error message is valid because you are attempting to install version 7.5.2 on a terminal server. Rumba requires a license/installer for Windows terminal server.
    The Evaluation version of 10.1 should run fine Citrix/WTS it's a full but time-limited version.

    best regards

  • Hello Andree,

    Because of the Citrix/WTS license checking, I could not launch Rumba v10.1, Just for trial, how can avoid this error message and get AS400 Display emulator working?



  • Hello Andree,

    We have totally uninstalled v7.5.2 and then installed v10.1, after trial version installation, we cannot launch it with the Citrix/WTS license issue. Should I download the package again? because I already installed it on another machine. Not sure if this is the reason.

  • Verified Answer

    Hi Alex Li,
    our Evaluation Software Rumba v.10.1 ( does install on Citrix/WTS and runs for 60 days without any message regarding a Citrix/WTS license being required.

    Could you please try and:
    1.Uninstall all Rumba software from the machine
    2. If there's any files left in the Netmanage  or in the Micro Focus Rumba Program Files folder please delete them manually.
    3. Delete the complete registry entry: Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\WallData

    good luck


  • Hello Andree,

    I have tried your instruction to delete the directory and delete the registry folder, then do restart , reinstall. I still get same error. this issue was not happen on another machine which does not have v7.5.2 installed before, and it does not have RDS Role enabled.

    Do you think RDS Role on my machine would be an issue for license checking? we don't use Citrix/WTS at all, why does it check such license?

    It would be great if you can help further. Are you able take a web meeting with me so I can share screen with you?

    Thanks a lot!