This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Unable to save a recorded macro

I have been trying to record a macro to perform the same actions again. I'm able to record the macro. But when i stop the recording the recorded macro is not getting saved. I'm getting error like "unable to save the file, due to the file format". So, i have tried giving the macro name.ebm while starting the recording. Even after doing it I'm getting same error. I'm using attachmate Extra! X-treme. 

Can anyone please provide me a solution for this.


Mainframe Access
  • Hi Nave,

    1. What version of Extra! are you running (see "Help" | "About Extra!")
    2. Can you post a screenshot of the error message?
    3. Are you attempting to save the macro on your local harddisk?
    4. If you launch the Extra! Basic Macro Editor are you able to save file from it?


  • Hi Tom, 

    1)Help files are not accessible, "getting error while opening .hlp files", 

    In about extra I'm unable find a relevant Solution for this issue.

    I'm using Extra! 9.3 version

    2) error screenshot below 

    3)Yes, I'm trying to save it in my local disk,  it is the same location where the demo macros are saved.


    4) yes, in macro editor I'm able to create a new file and save it. 

    I'm not able to record and save the macro, and also record pages option is also not working. In both options after clicking on the stop button , I'm getting the above attached error.

    Could you please help on this.  

  • Suggested Answer

    Hi Neve, 

    re: "Could you please help on this. I'm clueless", welcome to my world :-).

    First off I see you are using Extra! 9.3. SP1, please be aware that this version is no longer in support and although we added TLS 1.2 in this release, the implementation is vulnerable to several known attacks, including (but not limited to) the more publicised 
    FREAK, POODLE, Heartbleed and US-CERT vulnerabilities.

    My advice would be to seek to upgrade to the current release, so you get the most up to date security components (including TLS 1.3 Elliptical Curve cipher support.

    Also 9.3 SP1 was only certified against WIndows 8 and 8.1, if you are on WIndows 10 or 11 then, that might be an issue. Assuming you have been using Extra! 9.3 for several years (given that it released back in 2014), did this ever work for you? If yes, what has changed?

    Unfortunately, I don't have extra! installed at the moment, but looking at your "Record Macro" dialog, the "Make macro available to" appears to be pointing one of the subfolders in your Application directory, do you have write permissions to that location?

    If I remember correctly, under the Global Preferences, options there should be a setting to set the default macro folder location. Maybe changing that to a different location (one that is local on your disk and that you have full control over) would get you out of the bind in which you find yourself.


  • Hi Tom,

    Thanks for helping out. 

    I'm happy to let you know that, now I'm able to save the recorded macro.

    I just tried running the application in adminstrator mode. Now I'm able to record and save the macro.

    Nave Nesa

  • Awesome Nave, I'm happy you figured this out.