This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

How to disable large SDR.sqlite file in Plus folder of user profile

Hi, the background to this is for automating our companies TN5250 application have recently upgraded from Rumba 9.2 to Rumba 10.1.

While investing an issue with the performance and stability of Rumba I noticed in the users profile there was a large .sqlite file :-

C:\Users\<username>\AppData\Local\Micro Focus\Rumba\Plus\SDR.sqlite

When I opened this file I could see it contained a record of screens and keystrokes and it was obvious why this would get very large quickly with the amount of automated screen activity.

These are the steps I have carried out to try and disable this feature :-

1. Checked Plus Mode under the Plus menu was disabled.  I would have never disabled this feature but just a simple check.

2. Under Plus -> Settings there is a History section so ticked "Clear History on Disconnect", "Manual Capture Only" but this has not stopped the SDR.sqlite file growing.  I saved the session profile so that these settings did persist when I closed and open the session but that did not make any difference.

3. Ended the Windows Task with a description of "MicroFocus.Rumba.RumbaPlus.ScreenDataStorage" (MicroFocus.Rumba.SDBC) but not unexpectedly that also crashed the sessions.  I notice that this process does not take much CPU time but must result in a reasonable amount of IO at times saving to the SDR.sqlite file.

4. In the same folder as the SDR.sqlite there is a file sd.config but all that has in it is "[Culture] lang=en" and I could find not documentation of what could go in there and item 2 resulted in no changes to the file apart from updating the timestamp on it.

So in summary I am not sure if the screen recording to the SDR.sqlite file is affecting the performance of automating multiple Rumba sessions but I would like to fully disable it to see what difference it makes.

So the question is how do I fully disable Plus Screen History Recording.

Many thanks, Norman



  • Verified Answer

    As an update what I have found is that the SDR.sqlite file appears to be related to the Auto Complete feature and not to the Screen Recording as I originally thought. 

    So under Plus -> Settings I am disabling the Auto-complete function and the SDR.sqlite file has stopped growing. 

    Also given the usage am disabling Data Redaction (Compliance) as well and will see how it goes. 

    Needed to save changes back to .rsda file and see it updated as follows :-


    So tomorrow will run with that and see if makes much of a difference to overall automation performance.