Error in compilation

Hello everyone,

I have encountered this error while launching a compilation on an AIX environment with Cobol 8 : 

* Accepted - noint

*1502-U

Open fail : 'stdin'

cob64: error(s) in compilation: stdin

make: The error code from the last command is 16.

Stop.

  ABNORMAL END

Any help please ?

Tags:

  • Hello BOUSSAIDI Omar,

     

    Welcome to the Micro Focus Community site. Please note that you've asked this question on the Net Express/Server Express forum, but it sounds like you may be using Visual COBOL, which is a newer COBOL product with its own forum on the community site.

     

    The error you've reported is typically related to the compiler having problems opening one of the files associated with compilation:

    Failed to open file filename.

    You may not have write permissions for the destination folder of the specified file, the folder may not exist or the disk space may be insufficient.

     

    Can you confirm that you have read and write permissions in the directories where any source files exist, and where any files created by the build process would be created?

     

    A few more questions that may help us learn more:

     

    1. Can you share the exact version of COBOL being used? You can find this by running the following command after ensuring the environment for using COBOL is set:

    $ cat $COBDIR/etc/cobver

     

    1. Can you let us know the exact version of AIX in use by sharing the output of the following:

    $ oslevel -s

     

    1. Does this issue happen with all programs, or only certain programs?

     

    1. Did the program getting this error compile properly on another version or platform? If so, can you share what platform and version this worked on?
  • Hello,

    Thnak you for the reply.

    I can confirm that all the directories have read and write permissions neaded.

    For the Cobol version it's the Visual COBOL developpement hub 8.0

    As for the AIX version it's 7.3

    This error occured while launching a script that compiles a group of programs and it stops in the first one.

    This is the first plateforme for this client that functions with this version

  • Thanks for your update. It's not clear whether this is a problem with the COBOL product installation, or something specific to the COBOL programs being compiled. Here are a couple of things to try:

    First, it might be helpful to isolate the exact command being used to compile your programs within the make file. To do this, you can add the -n flag to your make command, for example:

    $ make -f mymakefile -n

    This will skip running the actual commands in the make file, and instead print out the commands that make *would* have executed. Can you try this, and share the complete "cob" commands being executed by the makefile?

    Second, you might also try compiling a simple Hello World program at the command line. Here's a simple 2-line COBOL program:

    $ cat hello.cbl

                display "Hello from Visual COBOL!"

                goback.

     

    After you've created the source file, set your environment (see the first command below to "source" or "dot in" a default Visual COBOL environment), then try compiling the program at the command line using:

     

    $ . /opt/microfocus/VisualCOBOL/bin/cobsetenv

    $ cob hello.cbl

     

    Does that generate an error? If not, try running the program with:

    $ cobrun hello

    Please let us know how it goes when you try the above.

  • hello, thank you for the update.

    I'm not allowed to make modifications on the code source so i tried to create the program hello.cbl and it gave me the next error : 

    *1001-E                                                                      **

    **    Character other than *, D, /, -, or $ found in column 7. Blank assumed.

    * 143-S***                                                                   **

    **    Unknown IDENTIFICATION DIVISION paragraph

         3splay "hello from Visual COBOL!"

    *1001-E                                                                      **

    **    Character other than *, D, /, -, or $ found in column 7. Blank assumed.

         4back

    *1001-E                                                                      **

    **    Character other than *, D, /, -, or $ found in column 7. Blank assumed.

    cob64: error(s) in compilation: hello.cbl

  • Please try starting the two statements in the hello world program in column 8 of the source code

    Chris Glazier
    Rocket Software - Principal Technical Support Specialist
    If you found this post useful, give it a “Like” or click on "Verify Answer" under the "More" button