This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Cobol Data file (.DAT) and Index file (.idx) Issue: Can't Write to Data file with error code "9/"

Hello everyone. Hope all is good. I am currently have a issue with writing record to "history.dat" and it is giving me an error of "9/"

The program has been working fine for the last 15 years however last month when trying to update/write to the history.dat file it is giving me an error. I was able to resolve the problem by going into Net Express and performing the "Fix File Index".  That resolve the issue and I was able to update the history.dat file. 

Moving forward to today, when trying to update the history.dat file I was getting the same error so I did what I tried before to get it to work however am unsuccessful even though Net Express say that the "Rebuild successful. Records Processed = 73216.

I'm not sure what is going on and hope someone can shed some light into this issue. I'm determined that it is something to do with the index file.

Some more information:

The file information:

history.dat   =  25,169 KB

history.idx   = 3024 kb

I notice last month that if I updated the history.dat with 100 record, it would proceed without any error however if I updated the history.dat with 102 record, it would give me the error. I'm sure there is no size limitation on the file and the disk space isn't full.

At any rate, if someone can please help, I would greatly appreciate it. Thank you.

Parents Reply Children
No Data